1 (edited by GParteduser2016 2016-10-05 00:09:03)

Topic: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

I downloaded gparted-live-0.26.1-5-amd64.iso from the Internet, assuming it to be the appropriate version of GParted for my 64-bit Dell notebook computer loaded with 64-bit Windows 10 Home Edition with a Globally Unique Identifier [GUID] Partition Table (GPT).  Gratefully this Windows operating system seems to be working reasonably well with the GPT.  To make the GParted, so-called “Live,” Recordable Compact Disc (CD-R) with which to boot my computer, in Windows 10’s “File Explorer” I right-touchpad-button-clicked on the downloaded .iso file and selected “Burn disc image” to use I think a disc-“burning” program in or associated with Windows Explorer to “burn” the bootable CD software onto a CD-R in my computer’s Digital Video Disc (DVD)-writing drive.   After changing my computer’s boot-mode settings, I could “boot” my computer from that so-produced CD-R and reach a screen containing a menu of choices with which to use GParted.  As the saying goes, this was “so far, so good” with the GParted “Live” CD-R.

With the GParted “default settings” selected I pressed down on the “Enter” key of my computer’s keyboard.  Then troubles became apparent.  No matter whether I had an external hard-disk drive connected to this computer or not, I could see error messages such as “No caching mode page found” and “I/O error, dev /sr0, sector” ….…   So clearly these problems were not with the external hard-disk drive.  And in at least one of my tests I eventually saw “missing ‘workdir.’”

I have “booted” a previous, 32-bit notebook computer containing a hard-disk drive containing more than one partition and a Master Boot Record (MBR) and I think a legacy version of the GRand Unified Bootloader (GRUB) in one of those partitions.  This might be the first period of time in which I tried to boot from a GParted “Live” CD-R a 64-bit computer with a hard-disk drive containing the GPT.  So far I have tried just one other choice in the GParted 0.26.1-5 menu, namely something like “other modes” and copying to RAM (Random Access Memory).  But unfortunately I think I had some similar types of error messages from GParted 0.26.1-5.


1) What is the cause of my problems?
2a) Can I remedy them?
2b) If so, how?


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

On http://gparted-forum.surf4.info/viewtopic.php?id=14139 on the Internet in the context of Input/Output errors using GParted on June 4, 2010 Internet Piscium Member reported “a bit of a problem booting from CDs on Dell desktops.”  My computer is a 64-bit Dell Inspiron-15, 3521 notebook computer containing a TSSTcorpDVD+-RW SU-208CB, Digital Video Disc (DVD) and Compact Disc (CD) drive.   So I’m wondering if the version of the Linux kernel used in GParted Live 0.26.1-5-amd64 may not have been compiled to use my Dell computer’s type of DVD/CD drive.  At least a partial test of this hypothesis could be to see if my GParted “Live” CD could be used to successfully boot another type of computer with another type of DVD/CD drive than the one in my computer.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

In the same “thread” I mentioned in the previous posting stevenshiau suggested using a Universal Serial Bus (USB) flash drive instead of a CD in the context of booting a computer from GParted computer software.  I found instructions for doing that in multiple ways within http://gparted.org/liveusb.php#linux-setup.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

And according to Thoughtful Skeptic within http://www.bleepingcomputer.com/forums/ … indows-8/, a Dell Inspiron-15 computer is supposed to be “bootable” from a USB drive.  But when I looked among the boot options for this computer I did not find one for booting from a USB drive.

5 (edited by GParteduser2016 2016-09-26 05:18:23)

Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

According to http://www.tomshardware.com/answers/id- … 3521.html, it appears that when no option for booting from a USB drive is listed in “Setup” for my type of computer that I may have to have a bootable USB drive inserted into a USB port of my computer for there to presumably be such a boot option.  And I expect that the option for booting from a bootable, USB flash drive should be listed above any other possible boot options at that time in order for such booting from a USB flash drive to take place.  I might not have ever booted my type of computer from a bootable, USB flash drive.  So if I were to try this, it might require experience for me to get it to work properly.

The alternative of finding an appropriate Linux driver for my computer’s DVD/CD drive and compiling it into a special version of the Linux kernel could be challenging.  But even if I would be successful in doing all of that, I still would not know how to incorporate that special Linux kernel into a version of GParted Live.

By the way, I tried booting my computer from the GParted “Live” CD in the “fail-safe” mode found in the GParted, “Live,” 0.26.1-5-amd64 menu.  And unfortunately that attempt to run GParted from a CD also failed using my type of computer.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

In your first post you mentioned that an earlier 32 bit version worked on a different computer.

The 32 bit versions of GParted Live will work in both 32-bit and 64-bit computers with either MBR or GPT.

If you still have an older copy of GParted Live (or a live distro) you might try booting with it to see if it works with your computer.

Regarding the current version, it is advisable to check the MD5SUM of the .iso file to ensure that the downloaded .iso file is not corrupted.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Thanks for kindly taking some time to post something here.  I could "paste" my downloaded .iso file into a window on https://emn178.github.io/online-tools/md5_checksum.html on the Internet and obtain the md5 checksum for it.  In the READ-ME file within the 0.26.1-5 directory of GParted downloads, which I opened with the Windows computer program WordPad, I found the MD5 checksum for my downloaded, gparted-live-0.26.1-5-amd64.iso file.  Those two MD5 checksums were exactly equal.  So my downloaded, .iso (International Standards Organization) file was evidently not corrupt.

The next thing to check is whether I can get an old version of GParted to work using my Dell computer.  But even before I try that it is important to realize that the versions of the Linux kernel used in them are likely to be different, since they were likely produced at different times.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Another thing to try is to see if any any Live CD/DVDs will boot on this computer.

Also if your computer has UEFI with Trusted Boot enabled then you will likely need to disable this feature for GParted Live to boot.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Your suggestion of trying older versions of GParted was excellent, gedakc, probably short for Curtis Gedak, one of the developers of GParted!  Thanks for your kindly provided suggestions!  Here are my results after booting my 64-bit Dell, Inspiron-15, 3521 notebook computer from some older, GParted “Live” CD-Rs.  My results were that the partitions or else the whole hard-disk drives were shown in GParted for both my internal and external hard-disk drives when booting my computer from each of the following versions of GParted, "Live" on CD-Rs:

GParted “Live” Version      Kernel Version Used   My Date on My CD-R
0.16-2-11-i486                  Perhaps 3.11.7           December 10, 2013
                                          i686 or 3.11-2-486

0.9.0-7                              2.6.39-2-486               July 28, 2011

0.7.1-1                              2.6.32-5-486               December 15, 2010

0.3.9-13                                     ?                         None

At first I saw only the partitions on my Dell notebook computer’s internal hard-disk drive shown on the main window in probably each of the four, above, old versions of GParted.  But eventually I noticed that either via the “GParted” menu, “Devices” or “Device, /dev/sdb (232.88” or nearly the same “GiB)” or in nearly the upper-right-hand corner of the GParted main window by clicking on a downward-pointing arrow and selecting “/dev/sdb (232.88” or similar “GiB)”, I could gratefully have the contents of my external hard-disk drive displayed when it was connected to my Dell, notebook computer via a pair of Universal Serial Bus (USB) connectors and ports.  I did not try to make any changes to either one of my hard-disk drives in the year 2016 using any of the above, older versions of GParted.

Again it was in gparted-live-0.26.1-5-amd64 that I had the various errors, such as Input/Output (I/O) errors, that I mentioned and could not get deep enough into GParted 0.26.1-5-amd64 with my Dell notebook computer to see the partitions on my internal hard drive and see the size in GibiBytes GiB of my external hard-disk drive in a main window of GParted.  Incidentally before trying gparted-live-0.26.1-5-amd64, I mistakenly tried gparted-live-0.26.1-5-i686 and also had at least one I/O error.  I guess that gparted-live-0.26.1-5-amd64 may be using a version of the Linux kernel higher than 3.11..., since version 3.11… of the Linux kernel was probably used in version 0.16-2-11-i486 of GParted late in the year 2013.

I haven’t tried to boot my computer from a USB flash drive prepared with GParted, “Live,” 0.26.1-5-amd64.  But I did notice that when I had a USB flash drive connected to a USB port of my Dell notebook computer that “USB Storage Device” became one of the “LEGACY BOOT” options after powering on my computer a couple of times, in each of those times tapping the F12 key, and during the first one of those two boots selecting something like Legacy boot, secure boot mode or secure mode off.  I suppose that for security of one’s computer data it is better for one’s computer to not be connected to the Internet than to be connected to the Internet when choosing “secure mode off” or “secure boot mode off.”


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Generally I/O errors indicate a hardware problem.  If your computer and CD/DVD drive work with other Live CDs, then perhaps the issue is with the actual compact disc used when 0.26.1-5-amd64 was burned to disc.

If you have a spare USB flash drive then perhaps you might try setting it up with 0.26.1-5-amd64 and then booting your computer with it.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Thanks for kindly posting something here, Curtis Gedak.  Please note that I had Input/Output errors when attempting to "boot" my 64-bit Dell, Inspiron-15, 3521 notebook computer with bootable, Recordable Compact Discs (CD-Rs) produced from both gparted-live-0.26.1-5-amd64.iso and gparted-live-0.26.1-5-i686.iso, but no such serious errors that I noticed when recently booting my computer using four older, GParted, "Live" CD-Rs or a non-GParted "Live" CD-R.  I am suspicious that the version or versions of the Linux kernel used in GParted 0.26.1-5-amd64 and 0.26.1-5-i686 may not be able to work with my Dell computer's TSSTcorpDVD+-RW SU-208CB, Digital Video Disc (DVD) and Compact Disc (CD) drive.  A minor problem using one or more of the old versions of GParted I listed two postings above this one in this "thread" of postings is that one Mebibyte (MiB) of unallocated space were listed as being on my external hard-disk drive when they were I suppose more likely on my Dell notebook computer's internal hard-disk drive.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

This unallocated MiB is left by default since several years, for compatibility with the newer storage media (4K sector hard drives, SSD).

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Thanks, moderator class413, for kindly posting some information about the one-MebiByte (MiB) of unallocated space on some modern hard-disk drives.  And thanks, Curtis Gedak, for posting information in this "thread" of postings.

I took my “bootable,” GParted, “Live,” 0.26.1-5-amd64, Recordable Compact Disc (CD-R) to a store with employees who sell and I guess might work on computers.  Employees of that store kindly performed test “boots” using that CD-R on a Dell, Inspiron-15, 1545 computer loaded with Windows 7 and a Hewlett-Packard 15, r131wm notebook computer loaded with probably Windows 10, which, based on Internet information, are likely each 64-bit computers.  As usual when the GParted menu was reached, I think Gparted’s “default settings” were selected.  But after waiting a short while in each case the main GParted window showing the detected partitions of the internal Hard-Disk Drives (HDD) was not reached.  There is a question whether there would have been success or not if we had waited several minutes.

Back to my 64-bit, Dell, Inspiron-15, 3521 notebook computer, I renamed the same downloaded gparted-live-0.26.1-5-amd64(1).iso file to gparted-live-0.26.1-5-amd64.iso and in 64-bit Windows 10 Home Edition right-”button”-clicked on that renamed file in File Explorer and selected “Burn disc image” with a new, blank CD-R in my computer’s Digital Video Disc (DVD) drive.  While “burning” that disc image I set that “burning” to be verified.  The result of that disc “burning” and verification of it was “The disc image has been successfully burned to disc.”  Along with this result recall that the downloaded .iso (International Standards Organization) file had the correct md5 or MD5 checksum.   Conclusion: There was no error whatsoever in either the downloading or “burning” processes in the production of this second, GParted “Live,” 0.26.1-5-amd64, bootable CD-R.  Yet, Input/Output errors were still found when attempting to boot my 64-bit, Dell, Inspiron-15, 3521 notebook computer beyond “default settings” in GParted 0.26.1-5-amd64 using this CD-R.

I had an eight-GigaByte (GB) flash drive that had been prepared in the file system 32-bit File Allocation Table (FAT32).  I eventually deleted all of the files on that flash drive, which should have left that flash drive in the FAT32 file system.  From the options on and instructions on or via http://gparted.org/liveusb.php#linux-setup on the Internet I chose the computer program LinuxLive USB (Universal Serial Bus) Creator to prepare a “bootable,” USB flash drive containing GParted 0.26.1-5-amd64 software.  The results of that process were two possible ways to boot into GParted---1) either within the folder entitled VirtualBox on the USB flash drive by double-clicking on the file Virtualize_This_Key.exe or by 2) booting my computer from this USB flash drive.  The result of the way “1” was the message “This kernel requires an x86-64 CPU” (Central Processing Unit)”, but only detected an i686 CPU.”  This result seemed strange because my computer has an x64-based, 1.9-GigaHertz (GHz), Intel Core i3227U CPU.  But by way “2” I gratefully could reach the main, GParted window listing six partitions and one MebiByte (MiB) of unallocated space.

But even though this was a success, I noticed a message including “dir” in it, perhaps the message “missing ‘workdir,’” before reaching later, GParted, 0.26.1-5-amd64 screens.  Since I had seen that kind of a message in some earlier boots of computers from GParted, 0.26.1-5-amd64, “Live” CD-Rs, that was a clue that earlier both an employee of the computer store and I might not have given GParted enough time to “reach” its main window showing the partitions found.  So again I tried booting my Dell computer using such a GParted, 0.26.1-5-amd64, “Live” CD-R, first using GParted’s “default settings,” but this time being willing to wait up to a few minutes.  I could get no farther than a message including “NO WARRANTY” in it.

In my next attempt to boot my Dell computer from that same GParted, 0.26.1-5-amd64, “Live” CD-R I chose the “Fail Safe mode” of GParted instead of “default settings” and again was willing to wait for minutes, if necessary, for that whole process of booting and moving toward the main GParted windows showing the partitions it “found.”  Gratefully this time that window was successfully reached!  However, in continuing I could not shut GParted down normally.  So I exited GParted by pressing the on-off, electric-power button above my computer’s keyboard.

I admit to not understanding some details of the above results.  During the minutes of time in one or both of the last two attempts to boot my computer from my GParted, “Live,” 0.26.1.-5-amd64 CD-R I could hear the CD drive starting in short spurts and stopping.  So I guess GParted was “trying” multiple times and/or in multiple ways to “get itself going” with my computer’s CD drive.  Before success I noticed that a particular sector of my CD-R was referenced multiple times with an Input/Output (I/O) error [But again I had I/O errors with another GParted CD-R prepared from a .iso file with the correct md5 checksum and with no errors in its “burning” process.].  The fact that boots from my first GParted 0.26.1-5-amd64 CD-R were at least slow on three different computers is puzzling.  Since the booting was much smoother and faster from my GParted-prepared, USB flash drive than from the Gparted-prepared CD-Rs, the tentative conclusion is that GParted 0.26.1.-5-amd64 had trouble with the Digital Video Disc (DVD)/CD drives on all three of the tested computers.  The part of this tentative conclusion that for the moment is rather hard to accept is in GParted 0.26.1-5-amd64 having some trouble with the CD drives in three different computers.  I guess that the version of the Linux kernel used in gparted-live-0.26.1-5-amd64.iso might be at least 4.1.4-1, since the earlier version 0.26.1-3 of GParted used that version of the Linux kernel (http://gparted.org/news.php?item=all).  So perhaps there could be a problem in the version of the Linux kernel used in GParted 0.26.1-5-amd64 for the TSSTcorpDVD+-RW SU-208CB, DVD (Digital Video Drive)/CD drive in my 64-bit, Dell, Inspiron-15, 3521 notebook computer and, assuming that the computer-related store did not change the factory-installed DVD drives in the following computers, in the 64-bit, Dell, Inspiron-15, 1545 computer loaded with Windows 7 and an HL-DT-ST DVD+-RW GT10N drive (http://www.notebookcheck.net/Review-Del … 034.0.html) and the 64-bit, Hewlett-Packard, 15-r-131wm computer loaded with Windows 10 and a SuperMulti DVD “burner” drive (http://support.hp.com/us-en/product/HP- … c04504168/).


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

If I read the last post correctly, it appears that you were able to boot GParted Live using the failsafe option.  That is good news because that way you would at be able to use GParted.

Often USB flash drives have faster read times than optical CD/DVD drives so this would account for booting from USB flash drive being much faster than from CD/DVD.

If you see I/O errors reading the CD media, then there is an issue with the CD/DVD drives reading that particular CD/DVD.  Sometimes burning the image using a different computer with a different CD/DVD drive can resolve the issue.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Thanks for kindly posting some information here, Curtis Gedak.  In my case I think the slowness in getting deep into a GParted, "Live," Recordable Compact Disc (CD-R) may have been troubles "reading" my GParted, 0.26.1-5-amd64, "Live" CD-Rs, based on some reported Input/Output (I/O) errors and my hearing the CD start turning and soon stop turning, start turning and soon stop turning, et cetera.

Now I quote your writing: "If you see I/O errors reading the CD media, then there is an issue with the CD/DVD drives reading that particular CD/DVD.  Sometimes burning the image using a different computer with a different CD/DVD drive can resolve the issue."

And now I comment on that writing of yours.  After thinking about your writing, there appears to be some good logic in it.  However, I recently produced another type of "Live" CD-R, not a GParted "Live" CD-R, using my Dell computer and, of course, its CD writer and did not have any I/O errors that I noticed when trying to boot my computer from it.  And, as I have already reported, with my computer and its CD drive I could have four old, GParted, "Live" CD-Rs "read" by my computer's CD drive.  And I don't recall any such I/O errors in my computer's CD drive "trying" to "read" any of those CD-Rs.  So I return to the hypothesis that the version of the Linux kernel used in GParted 0.26.1-5-amd64 may not be ideal for my Dell computer's TSSTcorpDVD+-RW SU-208CB, Digital Video Disc (DVD) and Compact Disc (CD) drive and a couple of other computers' CD drives.

16 (edited by GParteduser2016 2016-10-07 01:44:04)

Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

I prepended my posting title here with “[Solved]” because by selecting the “Fail Safe” option in GParted 0.26.1-5-amd64 and waiting for perhaps some minutes I could eventually see a list of detected partitions on my Dell computer’s internal Hard-Disk Drive (HDD) and see my external HDD listed.  But again from the repeated sounds of my computer’s CD writer start to turn and stop turning and the Input/Output errors I saw while running that version of GParted on a “Live” CD-R, it appeared that that version of GParted was “struggling” with my computer’s TSSTcorpDVD+-RW SU-208CB, Digital Video Disc (DVD) and Compact Disc (CD) drive.  And I still have some questions.

From a GParted Web page I found that the version of the Linux kernel used in a GParted 0.16.2-11-i486, “Live” CD-R is 3.11.7-1.  That kernel worked well with both my present computer’s CD writer and my external HDD [a 250-GigaByte (GB), Samsung HM250HI, SATA (Serial Advanced Technology Attachment), HDD in a Kingwin model-ATK-25U-BK, SATA-to-USB (Universal Serial Bus) enclosure].  Another type, not GParted, of  “Live” CD in which I have been interested did not display my external HDD, but worked well with my computer’s CD drive.  So to possibly improve or remedy each of those types of “Live” CDs for my computer hardware I’m interested in the possibilities of replacing the kernels in each of them with version 3.11.7-1, or one very similar to it, of the Linux kernel.

But I have encountered some difficulties.  First from https://www.kernel.org/category/faq.html I learned that kernel designations of the form x.xx.x-x are modified kernels “produced by distributions.”  So I guess that either someone working on GParted software or someone working on the Debian/GNU (GNU’s Not Unix) Linux distribution used in GParted (https://en.wikipedia.org/wiki/GParted) may have modified version 3.11.7 of the Linux kernel to produce version 3.11.7-1 of it.  Were the modifications of kernel 3.11.7 to produce kernel 3.11.7-1 made for GParted or for Debian/GNU Linux?  And what were those modifications?

The next problems were 1) that by clicking on a hyperlink on https://www.kernel.org/pub/linux/kernel/v3.x/ I could not obtain version of 3.11.7-1 of the Linux kernel, but could obtain version 3.11.7 of it; and 2) version 3.11.7 of the Linux kernel obtainable via the cited hyperlink was a collection of 43,989 source files likely written in the C computer language.  But fortunately I should be able to obtain initrd and vmlinuz files ready to use from within gparted -live-0.16.2-11-i486.iso, which fortunately I could download on October 6, 2016 from https://sourceforge.net/projects/gparte … .16.2-11/.  Would I be permitted to use those initrd and vmlinuz files in place of probably other versions of those files in GParted 0.26.1-5-amd64 and the other, non-GParted, free, “Live” CD I mentioned?


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Please, take into account that there is non just the Linux kernel, there are various libraries too as well as additional software packages to be compatible in order to create a working GParted live cd.

I don't know if it is a good idea to make a cd for a recent GParted version based on an old Linux kernel. Of course, you can try to modify and improve it, under the terms of the respective licences for the various parts.

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

The GParted Live image is based on Debian Live (SID) with our own compiled version of GParted and a patched version of parted.  We do our best to ensure that it works on many different computers, but cannot guarantee that it will work on all computers.

If you encounter difficulties with booting GParted Live, then I recommend working directly with the Debian Live developers using a plain vanilla version of Debian Live.

Please note that GParted is included on many GNU/Linux distros so if you are aware of one that works better with your hardware then you might consider using it.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Hello, Curtis Gedak.  Thanks for your contributions in developing GParted and in this “thread” of postings.

More evidence is pointing toward there being a problem in the Linux kernel and/or the GParted 0.26.1-5-amd64 computer code for my Dell computer’s type of Digital Video Disc (DVD)/Compact Disc (CD) writer, namely a TSSTcorpDVD+-RW SU-208CB, DVD and CD drive.  I found a friend who was willing to let me “burn” the GParted 0.26.1-5-amd64, .iso [International Standards Organization] image file, which had the correct md5 checksum, to disc using his Hewlett-Packard (HP) 15-f233wm computer and its HP DVDRW, DU8A6SH DVD and CD writer.  His computer was purchased only a few months prior to October 7, 2016.  I think I verified that disc-“burning” process.  Then I tried “booting” my Dell computer with that so-produced Recordable CD (CD-R) and obtained Input/Output (I/O) errors using the default settings and separately “other modes,” then “Failsafe mode” settings of GParted.  Again GParted on that CD-R seemed to be “struggling” with my computer’s CD drive, but eventually could reach the list of detected partitions on my Dell computer’s hard-disk drive in the “other modes,” then “Failsafe mode” of GParted.  And when trying to shut down GParted, the computer’s pointer arrow “froze” on the computer screen, meaning I could not move it by moving my finger over my computer’s touchpad.  But by pressing my Dell computer’s power button I could get out of that situation.  The result of the I/O errors along with my past results means that it made no difference whether I “burned” that GParted image to disc using my friend’s HP or my Dell computer.---In either case when booting my Dell computer using a Gparted-0.26.1-5-amd64, “Live” CD-R I encountered I/O errors in GParted’s “other modes,” then “Failsafe mode.”  I recently have not paid any attention to the disc-writing speed setting on my Dell computer and haven’t even been able to find out what it has been recently.  But I guess it might be the default writing speed when selecting “Burn image to disc” in Windows 10 and when having a .iso file opened in Windows Explorer on each of these two computers.---This is because after my recent load of Windows 10 onto my Dell computer I haven’t seen the writing speed for writing CDs in it so far in the year 2016; and my friend is not much of a computer expert; and I doubt if his friend, who is probably more of a computer-software expert than he is, would have made any changes to the CD writing speed on that computer.

But I think there is an even more-powerful argument than in the previous paragraph that GParted 0.26.1-5-amd64 “struggling” with my computer’s CD writer when “booting” my Dell computer using a “Live” CD-R of it may well be in the Linux kernel and/or GParted computer code.  Please read the rest of this paragraph slowly so that you can “catch” my logical connections from one sentence to the next one.  That is in the second Gparted-0.26.1-5-amd64, “Live” CD-R, that I produced from an md5-checksum-checked .iso file, using my computer I verified that disc-”burning” process and received a message from Windows 10 that that disc had been successfully “burned.”  That verification process had to be a disc-”reading” process!  So this meant that Windows could “read” that CD-R while it was in my computer’s CD drive!  But again GParted 0.26.1-5-amd64 really “struggled” to “read” especially a particular sector of that CD-R, with the repeated result of I/O errors “trying” to do it.  Therefore the problem GParted had in “reading” my so-produced CD-R was not a problem with the CD-R itself or with the CD drive, but with the software used in GParted 0.26.1-5-amd64 to “read” the CD-R using my computer’s CD drive.

This conclusion is well-supported by the fact that recently over a 15-day period of time using my Dell computer I produced two other types of “Live” CD-Rs and had no I/O errors when booting that same computer using each of them.  Yet I did have I/O errors when booting that same computer from GParted-0.26.1-5-amd64, “Live” CD-Rs that I produced during that 15-day period using that same Dell computer.  The hardware was without doubt the same and the “burn” settings were very likely the same in producing and “reading” all of the “Live” CDs I have so far mentioned in this paragraph.  This leaves only the computer software to explain the different results obtained when “booting” from those three types of “Live” CD-Rs.

So what were the differences between those other types of “Live” CD-Rs and the GParted-0.26.1-5-amd64, “Live” CD-R?  With ignorance on my part of the statements used in the computer codes of those three types of “Live” CDs, I doubt if they would be exactly the same.  But I am expecting the part of the computer code dealing with my Dell computer’s particular type of CD writer to mainly be in the Linux kernels, more specifically in the so-called “driver” files which I think are supposed to act as software “interfaces” between an operating system and the hardware device.  And the Linux kernels used in those three types of “Live” CDs were all different!  Not only that, but as you know, the version of the Linux kernel used in GParted has been changed over time.  And again I suppose that it is to a great extent within the Linux kernel that particular hardware is “handled” or “interfaced” within the computer software.  Therefore I suppose that it may mainly be the difference in Linux kernels used in versions 0.16.2-11-i486 and 0.26.1-5-amd64 of GParted that may explain the success with my Dell computer’s CD writer using the former version of GParted and the “struggles” with it using the latter version of GParted.

I have been in contact with a developer and/or author of one of the non-GParted types of “Live” CDs I have been discussing here.  The problem I had with it was in detecting an external hard-disk drive I have been using with my Dell computer.  The circumstances of that failure fit that developer’s expectation of there being a problem with the Linux kernel used in that type of “Live” CD for my type of external hard-disk drive in its enclosure.

The obvious solution for the use of both that type and the Gparted-0.26.1-5-amd64 type of “Live” CD with my Dell computer and external hard-disk drive is to replace the versions of the Linux kernels used in them with an earlier version of it which worked well with both my external hard-disk drive and my computer’s CD drive; and because of those kernel substitutions then make any other necessary changes in the software in the .iso files.  I am expecting that substituting version 3.11.7-1 of the Linux kernel could be the main part of one possible improvement of GParted 0.26.1-5-amd64 for my Dell computer’s type of CD writer.  For the other type of Live “CD” with which my external hard-disk drive was not listed, some adaptations of the Linux kernel 3.11.7-1 might be necessary to work well with the version of Linux used in it, as well as with my computer and external hard-disk drive.  I have written to a developer of that computer code requesting his help with his software either to make those adaptations for me in his computer code or to advise me how to make them.


Re: [SOLVED]Vs.0.26.1-5-amd64,Errors,"Live" Compact Disc;64-bit Win.10,GPT

Thanks, moderator class413 and Curtis Gedak, for kindly taking some time to post information here in this “thread” of postings.  Concerning Curtis’s suggestion of using a version of GParted in some distribution of the Linux operating system, I experimented with GParted within a 64-bit openSUSE Leap, 42.1 distribution of the Linux operating system on my Dell computer’s Hard-Disk Drive (HDD).  I have that operating system installed as a Virtual “Machine” (VM) within Oracle VM VirtualBox, and all of that within a 64-bit Windows 10 Home Edition operating system.  At first I found that that version of GParted only listed my internal HDD partitions that are associated with my openSUSE installation.  For example, my internal hard-disk drive’s partition containing my Windows 10 operating system was not “detected” by that installation of GParted within openSUSE within VirtualBox.  Then I connected my external HDD to my Dell computer.  In openSUSE’s “Devices” menu I clicked on “USB,” because my external HDD was connected to my computer via a couple of Universal Serial Bus (USB) ports, and found “GenesysLogic,Inc. USB Storage [0009]” displayed.  After clicking on that item the second time, eventually after checking again within that menu item I found a check mark beside that listing of that device, which I guess might have meant that that device was attached for use in my installation of the openSUSE operating system.  In openSUSE’s GParted clicking on its “GParted” menu, then within it on “Refresh Devices,” and then by clicking on the downward-pointing arrow to the right of /dev/sda … near the upper-right-hand corner of GParted’s main window, I could gratefully see the contents of my external HDD displayed with the symbol of a door-unlocking key in that line.  But on right-touchpad-button clicking on that line, the words “Format to” were in grey-colored text, which meant that I would not be able to format that HDD from within openSUSE.  I’m guessing the reason for that symbol of a key could be that I did not have permission for myself to make changes to that HDD from within openSUSE.  If so, that may be good, in a way, to protect against a stranger trying to access the backup of the Windows-containing partition that I had at the time on that external HDD.  And perhaps a way to solve that problem for myself might be to change the permission for accessing that HDD from within File Explorer or Disk Management in my Windows-10 installation on the same computer as the openSUSE installation.

Then if that possible permission problem could be solved, perhaps GParted in openSUSE might in principle be usable to format an external HDD connected to my Dell computer.  Currently my openSUSE Linux operating system is using version 4.1.31-30-default of the Linux kernel.

Within GParted in my installation of the openSUSE operating system I didn’t see any way to make a “bootable,” GParted, “Live” Compact Disc (CD) or a .iso [International Standards Organization] file which might in principle be “burnable” onto a Recordable CD (CD-R) for that purpose.  That could involve writing some kind of a Linux operating system in a .iso file to use as the “Live” Linux operating system on such a “bootable” CD.  If that feature does not presently exist in GParted installations in distributions of the Linux operating system, it might be a good feature to add to them.