Topic: issue with live cd - [sr0]

I have come across an error with Gparted live v. 0.5.2-9.
Booting the same PC with 0.4.5-3 there is no error, so this looks like a bug.

After clicking on "Don't touch keymap" and before choosing an option for "Loading language settings", I get 6 error messages, repeated twice. This issue is repeatable, though the actually sector numbers vary slightly.

Below are the error messages. I copied them by hand so typos can be expected. Also did not copy timestamps at the beginning to save time.

[sr0] Result: host byte=DID_OK DriverByte=DRIVER_SENSE
[sr0] Sense Key: Illegal Request [current]
[sr0] Add. Sense: Illegal mode for this track
[sr0] CDB: Read(10): 28 00 00 00 e3 b8 00 00 01 00
[sr0] end_request I/O error, dev sr0, sector 233184
[sr0] Buffer I/O error, dev sr0, logical block 58294??

... the above repeated two more times

Moreover some of the messages above appear before "Don't touch keymap", but there is not enough time to copy them down, so I did not.

I verified the md5 checksum after downloading and it was ok. To rule out errors with burning the CD I burned the same image twice, first with Brasero on Linux, secondly with Nero on Windows. The problem happens with both CDs.


Re: issue with live cd - [sr0]

If you use the same brand CD, it's not easy to make sure if the problem is on the CD disk and drive compatibility... Therefore maybe you can give USB flash drive version a try?

BTW, I have uploaded GParted live 0.5.2-10 in the testing branch, which uses a newer kernel. Maybe you can give it a try, too.


3 (edited by ander666 2010-06-01 15:37:44)

Re: issue with live cd - [sr0]

I have the same errors on RHEL4 u5, IBM Blade server HS21 but I can work with Gparted. I haven't tested if I can resize the partitions yet.

This happened if I booted GParted from the remote CDROM. If booted from the local CDROM all was without errors.



Re: issue with live cd - [sr0]

Hi Steven,

The reason I burned the second CD with Nero is because it has a feature whereby the image is verified, that is, after the CD is burned Nero reads it back and compares it with the original. Nero reported no errors so I am pretty confident that there were none. This is a feature that Brasero unfortunately lacks.

Taking a cue from Ander, I should say that despite the error that I reported, Gparted worked. I deleted, added and changed the size of a few partitions and apparently there were no errors with the partitions themselves. So that is good.

There were however more errors after I pressed the button to restart the PC, but I did not write them down.

As I said, version 0.4.5-3 on this same PC does not have these errors.

OK, I will try the new testing Gparted later on and will report the result.



Re: issue with live cd - [sr0]

I tested 0.5.2-10. I downloaded it, verified the md5, and put it on a USB stick.

I have good news and bad news.

Good news: the errors I reported with the previous version 0.5.2-9 at startup and reboot disappeared. Great.

Bad news: I did a quick test of creating a partition and it failed three times in a row (so it is repeatable).
I saved the details. They are pasted below.


GParted 0.5.2

Libparted 2.2
Create Logical Partition #1 (ext3, 4.53 GiB) on /dev/sdb  00:00:01    ( ERROR )
create empty partition  00:00:01    ( SUCCESS )
path: /dev/sdb12
start: 916958133
end: 926452484
size: 9494352 (4.53 GiB)
set partition type on /dev/sdb12  00:00:00    ( SUCCESS )
new partition type: ext3
create new ext3 file system  00:00:00    ( ERROR )
mkfs.ext3 -L "junk" /dev/sdb12
mkfs.ext3: /lib/libblkid.so.1: version `BLKID_2.17' not found (required by mkfs.ext3)


Re: issue with live cd - [sr0]

Oops... Yes, this is a bug about e2fsprogs in Debian Squeeze:
I have fixed this issue (hope), and another GParted live 0.5.2-11 was uploaded in the testing branch. Could you please test it and tell us the results?


7 (edited by Piscium 2010-06-03 08:12:58)

Re: issue with live cd - [sr0]

I tested 2-11 on a usb pen drive. The problem I reported yesterday of not being able to format an ext3 partition was solved. So I managed to successfully create, relabel and delete a partition.

Yesterday I only tested 2-10 on usb. Today after the success of the test above, I decided to burn a CD and do the same test.

Tests on CD

2-11 is far worse than 2-9 with respect to the errors I reported, but the errors happen before the keymap question. In general 2-11 is very slow when booting. Nevertheless after it boots GParted works well, just as 2-9.

I have measured the time it takes from when boot starts until the graphical desktop appears:
0.5.2-11: 5 minutes 30 seconds
0.5.2-9:   2 minutes 10 seconds
0.4.5-3:   1 minute   15 seconds.

0.4.5-3 has always been reliable on my PC and is fast.

Conclusion: 0.5.2-11 seems fine for USB but I would not recommend it for a CD.

(I did only a simple test of creating and deleting a partition so obviously much more testing would be needed to really say 2-11 works well).


Re: issue with live cd - [sr0]

Could you please test to boot the same GParted live 0.5.2-11 CD on different machine?
By doing this, we can isolate the problem is on the hardware or the software.



Re: issue with live cd - [sr0]

Hi Steven,

My home PC where I did the tests above is a Dell Dimension 3000. It is old but still usable, it has a 3GHz Pentium 4 and 2 Gbytes RAM.

At work just about everything is Dell. I tested two CDs on two PCs. The results are below.

Dell Optiplex GX520

0.5.2-11: 3 minutes 40 seconds
0.5.2-9:   2 minutes 10 seconds
0.4.5-3:   not tested

Dell Optiplex 745

0.5.2-11: 2 minutes 15 seconds
0.5.2-9:   Could not complete the test because the screen blanked out before the choice of keymap. This happened three times.
0.4.5-3:   not tested

And I am not the only one having this type of error as can be seen here:

The error message in that thread is that same as one of the messages I get.

10 (edited by Piscium 2010-06-05 20:52:34)

Re: issue with live cd - [sr0]

Needlessly to say, it was not part of my plans for the month of June to test CDs with GParted! smile

The good thing thing coming out of this is that it is making me reflect about my use of CDs. I am thinking that if I buy a few pen drives then I can get rid of CDs. It is more ecological and would save me time.

Anyway, this has nothing to do with GParted development, but really, perhaps CDs should be de-emphasized, they are so last century!


Re: issue with live cd - [sr0]

Hi  Piscium,
I believe this is really a kernel/hardware support issue (Especially it's on some specific hardware), or the compatibility of CD and CD drive.
Here I just did a test with a CD, GParted live 0.5.2-11, on Acer Veriton M670. It boots into X about 62 secs then I can start to use GParted.
Maybe the next kernel update it will be better.



Re: issue with live cd - [sr0]

Hi Steven,

62 seconds sounds right, it is close to the 75 seconds I got with 0.4.5-3, and your PC is probably newer than mine.

So the conclusion seems to be that there is a bit of a problem booting from CDs on Dell desktops, both home and business models, with the latest version of GParted Live, yet if boot succeeds GParted itself works.

But I decided to stop using CDs so am not concerned about that any more.

To finish I would like to thank your for making Live GParted available to the community.



Re: issue with live cd - [sr0]

No problem.
Yes, it's better to use USB flash drive if you can. It's faster, more flexible, easier to carry...


14 (edited by xseoer 2010-07-01 09:42:43)

Re: issue with live cd - [sr0]

stevenshiau wrote:

No problem.
Yes, it's better to use USB flash drive if you can. It's faster, more flexible, easier to carry...


Hi guy , do you know how to make boot system with USB flah ? smile


Re: issue with live cd - [sr0]

Hi guy , do you know how to make boot system with USB flah ?

You need to set the USB port in priority in the boot sequence section of the BIOS setup. Of course, thiw is valid with motherboards of the late 10 years or so.

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: issue with live cd - [sr0]

If booted from the local CDROM all was without errors.