1 (edited by rooobertek 2009-12-20 09:18:20)

Topic: [SOLVED] partition with ext3 kaput


I dont know if this is the same problem like http://gparted-forum.surf4.info/viewtopic.php?id=13777 , but I think yes.
I resized ext3 partition and it is now "damaged".

#fdisk -l -u
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x95f3457a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    13776895     6887424   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2   *    13783770   117097784    51657007+  83  Linux
/dev/sda3       117097785   294262604    88582410   83  Linux
/dev/sda4       294278670   312576704     9149017+   5  Extended
/dev/sda5       306552393   312576704     3012156   82  Linux swap / Solaris
/dev/sda6       294294798   306552329     6128766   83  Linux

Partition table entries are not in disk order

#parted /dev/sda unit s print
Model: ATA HITACHI HTS54161 (scsi)
Disk /dev/sda: 312581808s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start       End         Size        Type      File system     Flags
1      2048s       13776895s   13774848s   primary
2      13783770s   117097784s  103314015s  primary   ext3            boot
3      117097785s  294262604s  177164820s  primary   ext3
4      294278670s  312576704s  18298035s   extended
6      294294798s  306552329s  12257532s   logical   ext4
5      306552393s  312576704s  6024312s    logical   linux-swap(v1)

Help me please


Re: [SOLVED] partition with ext3 kaput

sorry, this is missing in first message


Re: [SOLVED] partition with ext3 kaput

Did you save a copy of the gparted_details.htm log file?
If so then please post it here.
If not, can you describe as best you can what actions you performed with GParted?

Which version of GParted or Live CD did you use?

4 (edited by rooobertek 2009-12-18 23:11:52)

Re: [SOLVED] partition with ext3 kaput

First operation occurs no problem (made partition smaller), after it i moved free space under next primary partition and created new ext3 filesystem.
The problem report was from fsck, somethink like partition size is bigger than physical size. I didnt know how to save it when i have this problem with disk...
Version was Gparted 0.5.0-3

(sorry for horrible english)


Re: [SOLVED] partition with ext3 kaput

The explanation helps to explain how the error occurred.

Can you try to run the following command from a Live CD?

e2fsck -f -y -v /dev/sda1


Re: [SOLVED] partition with ext3 kaput

error message:
The filesystem size (according to the superblock) is 23681818 blocks
The physical size of the device is 22145602 blocks

I already repaired it. In ubuntu rescue mode was possible to manualy mount /dev/sda3 (why?). So I .tar.gzipped whole partition and copied to external disk. After it was umount, mkfs.ext3 /dev/sda3, mount and untargzip. It takes very long time, but my computer now works fine.


Re: [SOLVED] partition with ext3 kaput

Thank you for reporting back with how you repaired your situation.

To help others with finding solutions to problems like these, it helps to edit the initial post and prefix SOLVED in front of the title.