Re: !! Invalid loop location (Gparted liveCD Guidance)

I'm sure it was just some simple kernel oops. I use vanilla kernel sources. The only patches I use are for reiser4 and squashfs.


Re: !! Invalid loop location (Gparted liveCD Guidance)

Newer kernels work better on new hardware.

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: !! Invalid loop location (Gparted liveCD Guidance)

be4truth wrote:

One solution that sometimes works is to pass following kernel option at boot prompt:

pci=nomconf ide0=0x1018,0x1010

It worked for me (intel q6600 on gigabyte ga-p35, Pioneer DVR-112 ATA and sata hdd, legacy mode in bios)


Re: !! Invalid loop location (Gparted liveCD Guidance)

I had a same problem.
My PC is SONY vaio note PCG-C1VJ.
CD-ROM drive was not recognized on booting process.
So I added next parameter to kernel parameter of the grub menu.


I could boot from liveCD and the problem was solved completely.

55 (edited by Rava 2008-01-30 11:06:00)

Re: !! Invalid loop location (Gparted liveCD Guidance)

I get the same error message on my Samsung Q40, but the CD-Drive is an external CD/DVD RW/R firewire IEE1??? drive.
I'm at the office right now and the Laptop is at home, I will try it with
# /dev/s[TAB][TAB]
and also with
# dmesg | grep -i cdrom
# dmesg | grep -i scsi
Some Linux-Live-CDs boot out of the box like the newest Knoppix 5.1.1, but I need to resize the single-Partition of the internal HD which is NTFS, and the knoppix gparted doesn't support that.

As far a I remember, the current qparted-live cd is able to do so or am I mistaken?

# /dev/s[tab][tab] gives nothing.
# dmesg |grep -i scsi gives nothing.
# dmesg | grep -i cdrom gives one or two drivers that are loaded, but no cdrom drive name or similar.

Update 2
Now I copied the gparted.dat to an USB-Stick, which gparted seems to find as /dev/sda1 [now a /dev/sg0 appears, which hasn't before. Could be 'cause of the delay caused by the USB-stick.]

And I gave the kernel command with loop=/dev/sda1/gparted.dat but that won't work.

Now I try the idea with cdroot= and scandelay as mentioned above. Hope this will be the working solution, then.


56 (edited by Rava 2008-03-13 06:50:29)

Re: !! Invalid loop location (Gparted liveCD Guidance)

It works now with just

scandelay=20 cdroot=/dev/sda1

when inserting the USB-stick with the gparted.dat on it.

That work's always faster than loading the gparted.dat from CD, I presume. So that's OK for me.