1 (edited by djfrodo 2024-01-24 05:54:04)

Topic: Error After Dual Boot Ubuntu Partition Resize Attempt

Hi All,

So I allocated 70gb to Ubuntu on a dual boot machine with a 1tb drive.

After a lot of dev work and a few years I realized I had become...a linux user.

I also only had 9gb left for Ubuntu.

So, I shrank the Window partition, booted into live Ubuntu via usb, changed the partition order and expanded the Ubuntu partition to take up the allocated space...and there was an error.

What's weird is Windows is correctly reporting the space is now gone from the Windows partition, and Gparted is showing the size of the Ubuntu partition correctly, but it's got the dreaded red error mark and Disk Analyzer is still showing only 9gb of free space.

I've run "Check" and still get the error on resize2fs.

Anyone have any ideas as to what's going on?

Here's the last part of the details/error message:

Check and repair file system (ext4) on /dev/sda5  00:00:11    ( ERROR )
calibrate /dev/sda5  00:00:00    ( SUCCESS )
path: /dev/sda5 (partition)
start: 1182461952
end: 1952471039
size: 770009088 (367.17 GiB)
check file system on /dev/sda5 for errors and (if possible) fix them  00:00:11    ( SUCCESS )
e2fsck -f -y -v -C 0 '/dev/sda5'  00:00:11    ( SUCCESS )
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

1306714 inodes used (26.85%, out of 4866048)
12092 non-contiguous files (0.9%)
1629 non-contiguous directories (0.1%)
# of inodes with ind/dind/tind blocks: 0/0/0
Extent depth histogram: 1258267/2974/2
17106841 blocks used (87.95%, out of 19451136)
0 bad blocks
5 large files

1087010 regular files
170333 directories
8 character device files
1 block device file
2 fifos
87288 links
49351 symbolic links (45452 fast symbolic links)
0 sockets
1393993 files
e2fsck 1.45.5 (07-Jan-2020)
grow file system to fill the partition  00:00:00    ( ERROR )
resize2fs -p '/dev/sda5'  00:00:00    ( ERROR )
resize2fs 1.45.5 (07-Jan-2020)
Please run 'e2fsck -f /dev/sda5' first.


Re: Error After Dual Boot Ubuntu Partition Resize Attempt

I have no idea why after successfully running e2fsck -f -y -v -C 0 '/dev/PTN' running resize2fs -p '/dev/PTN' fails saying run e2fsck -f.  I can only offer the same advice that I did the last time this situation occurred:
Re: Error growing partition because of ext4 FS grow error


Re: Error After Dual Boot Ubuntu Partition Resize Attempt

O.k. I'm answering my own question here so bear with me...

The first thing I tried was making a Usb bootable Gparted disc, which did exactly the same thing Gparted on the Ubuntu install disc did - nothing.

Still reported only 9gb free on the Ubuntu partition.

Out of desperation I installed Gparted with APT, just to see what would happen. I tried moving resizing with the native Gparted installed but I knew it would be locked because I was using it, and the locked (key) icon obviously told me so.

I rebooted and looked at Disk Usage Analyser and System Monitor and...

Voila - the disc now reports the correct size in both.

I rebooted into Windows and everything was fine...

So...I have zero idea why this worked, but for anyone who runs into this problem give it a try.