1 (edited by lucamax 2023-01-16 01:16:15)

Topic: [SOLVED] How to remove a ataraid partition ?

I found an old IDE 60 gb drive, I made on it a physical copy  of another hd with Clonezilla.

The 60 gb hard disk is not recognise by bios of an old Asus Tx-97 Pentium S motherboard, and in Linux MInt 21.1, the drive cannot be mount.

Gparted report it as a ataraid partition, allowing only formatting, but even if the procedure is succesfull, when drives are update, the partition returns to atadrive .


Re: [SOLVED] How to remove a ataraid partition ?

GParted reporting a drive as ataraid means the drive was part of an ATARAID array and still contains the ataraid format data.  To remove the ataraid format data overwrite it with zeros by doing the following in GParted:

1. Confirm that GParted shows the ataraid partition as inactive.
   (No key or lock icon at the end of the Partition name, and no Mount Point value).

2. Format the partition to Cleared and apply.

3 (edited by lucamax 2023-01-16 01:16:41)

Re: [SOLVED] How to remove a ataraid partition ?

Thanks for your reply.

Unfortunately it does not work.

The partition is inactive and and the format command to "clean" is succesfull, but the ataraid after reboot is still there.


BTW the translation in italian of "clean" format option with "pulito" is misleading, I would suggest the word "cancellare".

4 (edited by lucamax 2023-01-16 01:15:29)

Re: [SOLVED] How to remove a ataraid partition ?

I found a solution...

$ sudo dmraid -r -E
Do you really want to erase "pdc" ondisk metadata on /dev/sdb ? [y/n] :y

after that ...

$ sudo dmraid -x 
no raid disks

Now in Gparted the partition is "non allocated"


Re: [SOLVED] How to remove a ataraid partition ?

Format to > Cleared is meant to remove all signatures so that partitions are detected as unknown and whole disks as unallocated and unpartitioned.  I have raised this bug report to address this:
issue 220 "Format to Cleared not clearing "pdc" ataraid signature"