Topic: GParted not recognize Intel RST RAID

Hello everyone!

I try to partition an Intel Rapid Storage Technology (RST) RAID, but GParted cannot see it.

Motherboard : Gigabyte H470M DS3H r1.0, BIOS version : F5a
RAID : 1 (mirroring)
Disks : 2 x Kingston SSD A2000 M.2 NVMe

When I disable RAID and put disks in AHCI mode, then GParted can see them.

Any help will be appreciated! Thanks in advance!


Re: GParted not recognize Intel RST RAID

Run GParted telling it the device name like this:

sudo gparted /dev/DEVICE

Where DEVICE is the name of the RAID array.

Please show us your hard drive setup with that Intel RST RAID device enabled so that we might make GParted automatically recognise it in future.

sudo lsblk -o name,maj:min,rm,size,ro,type,fstype,label,mountpoint

3 (edited by dmvazquez 2020-12-08 20:25:28)

Re: GParted not recognize Intel RST RAID

Thanks mfleetwo for your time!

These are the output for those commands:

> sudo gparted /dev/DEVICE
> Could not stat device /dev/SERVIDOR - No such file or directory

> sudo lsblk -o name (already tried long command, but no luck)
> loop0
> sda
        |_ sda1

These are further info (from BIOS):

Intel RST
RAID level : RAID1 (mirror)
Bootable : yes
PCIe 1.0 : Kingston SA2000M8500G
PCIe 2.0 : Kingston SA2000M8500G
SATA Controller : Enabled
SATA Mode : Intel RST Premium with Intel Optane
Use RST Legacy OROM : Disabled

Booted USB in UEFI mode, and GParted in default settings.

I tried another partition software (EASEUS PM 15.0) with no luck either.
But adding drivers manually did the trick!

Hope this info help to find a solution!
Thanks a lot for your help!

I'll wait for a new version of GParted!