Topic: HDD not detected on GParted Live

Yesterday I tried to start a windows virtual machine from mac OS with virtualbox, I had created a 100 GB VDI virtual disk on my 2 TB Maxtor M3 hard disk, suddenly while I started the virtual machine the hard disk has disconnected and mac has given the error message, I tried again then the disk was no longer recognized, I tried to do the SOS of mac but it didn't help, I downloaded diskdrill and I eliminated the corrupt blocks and now the hard disk is not seen anymore! Neither from Mac OS nor from GParted, do any of you know what could have happened? thanks!


Re: HDD not detected on GParted Live

I think you have to check if the hard drive is working.
- You can try connecting the drive to another USB port. Eventually, you can try to change the connecting cable.

- You can try the hard drive to any other computer, to see if it is detected.

- Look if the drive is detected by the computer's BIOS.

- If the drive is detected by the BIOS, you can check the SMART info by running a Live Linux distro (GParted Live can be used for this, run the smartctl command from a terminal window).

- Under Linux, you can see the dmesg report from a terminal (as root or sudo) and look about error messages after you plug the disk.

- Use manufacturer's checking software to check the condition of the drive.

I remember some problems in the past with a Seagate (or Maxtor?) USB drive falling in sleep mode. I had to disable power save mode.

*** It is highly recommended to backup any important files before doing resize/move operations. ***