1 (edited by New_World_Man 2019-11-07 23:58:17)

Topic: [UPDATED] SLIGHT display issue before desktop manager starts

Version = gparted-live-1.0.0-5-amd64

For quite some time I havew had to specify xorg-driver=nouveau in the boot options.
Also resolution issues that I fixed with a script posted here - now turned in to a executable with more options, but not released yet - well unless you count about 5 people I know personally - just to test things really.

HOWEVER, a NEW display issue I just noticed (might have been in other versions, don't always upgrade right away)...


I like to see what is going on during boot, so I NEVER use to quiet boot option.
GParted live starts fine, then at a certain point while still in console mode screen goes blank.  BUT boot continues fine, wait for it, and display is back once the desktop manager starts.
Once that happens however, I also have a HUGE mouse pointer - that part I have worked around - it goes back to normal if you restart fluxbox, so to the file /etc/X11/fluxbox/init I added the line:
session.screen0.allowRemoteActions: true

Then to the /home/user/.flubox/startup file:
fluxbox-remote restart &

Just before the command:
exec fluxbox


If nomodeset is specified, I will see everything right up to attempting to start the X server, but X won't start due to a framebuffer issue of some sort (forget the exact message)

UPDATE 11/07/2019 -- I just tried it, it seems that specifying a video driver is no longer required, but there is still the slight issue of display before desktop manager starts.