1

Topic: Boot parameter findiso is no longer recognized

Hi,

I use a ntfs-formated usb-drive with several different iso-files. This usb-drive is bootable with Grub4DOS and it allows me to boot each iso-file without extracting the iso-file to the filesystem. Some people (including me) is calling this a MultiBoot-Stick.

For GParted Live 0.33.0-2 I used this config in Grub4DOS:

title GParted Live 0.33.0-2
find --set-root /GParted-Live-0.33.0-2.iso
map /GParted-Live-0.33.0-2.iso (0xff) || map --mem /GParted-Live-0.33.0-2.iso (0xff)
map --hook
kernel (0xff)/live/vmlinuz findiso=GParted-Live-0.33.0-2.iso edd=off boot=live locales=de_DE.UTF-8 keyboard-layouts=de union=overlay username=user config components noswap ip= net.ifnames=0 nosplash
initrd (0xff)/live/initrd.img

Now I tried to include the current version of GParted Live and failed. Here is the config:

title GParted Live 1.0.0-1
find --set-root /GParted-Live-1.0.0-1.iso
map /GParted-Live-1.0.0-1.iso (0xff) || map --mem /GParted-Live-1.0.0-1.iso (0xff)
map --hook
kernel (0xff)/live/vmlinuz findiso=GParted-Live-1.0.0-1.iso edd=off boot=live locales=de_DE.UTF-8 keyboard-layouts=de gl_batch union=overlay username=user config components noswap ip= net.ifnames=0 nosplash
initrd (0xff)/live/initrd.img

It seems, that the findiso is no longer recognized, since the initrd and kernel loads. After that it searches for some minutes for the iso-file of GParted Live, but can't find it. According to various webpages, findiso should work in Debian Live.

Any advice, what I should to to boot GParted Live with Grub4DOS?

2

Re: Boot parameter findiso is no longer recognized

Please give the latest stable GParted live 1.0.0-2 a try. A related issue about this has been fixed, and I am able to use this config for booting GParted live in grub2:

menuentry "Gparted live" {
    set isofile="/home/isos/gparted-live-1.0.0-2-amd64.iso"

    loopback loop $isofile
    linux (loop)/live/vmlinuz boot=live findiso=$isofile union=overlay username=user config components quiet noswap  ip= net.ifnames=0  nosplash
    initrd (loop)/live/initrd.img
}

Please let us know the results. Thanks.

Steven

3

Re: Boot parameter findiso is no longer recognized

stevenshiau wrote:

[...]
Please let us know the results. Thanks.

Did not work with 1.0.0-2. It still seearches for a long time and failes again:

title GParted Live 1.0.0-2
# https://gparted.org/download.php
find --set-root /GParted-Live-1.0.0-2.iso
map /GParted-Live-1.0.0-2.iso (0xff) || map --mem /GParted-Live-1.0.0-2.iso (0xff)
map --hook
kernel (0xff)/live/vmlinuz findiso=GParted-Live-1.0.0-2.iso edd=off boot=live locales=de_DE.UTF-8 keyboard-layouts=de gl_batch union=overlay username=user config components noswap ip= net.ifnames=0 nosplash
initrd (0xff)/live/initrd.img

BTW: I am using gparted-live-1.0.0-2-i686.iso.

4

Re: Boot parameter findiso is no longer recognized

tom.candle wrote:
stevenshiau wrote:

[...]
Please let us know the results. Thanks.

Did not work with 1.0.0-2. It still seearches for a long time and failes again:

title GParted Live 1.0.0-2
# https://gparted.org/download.php
find --set-root /GParted-Live-1.0.0-2.iso
map /GParted-Live-1.0.0-2.iso (0xff) || map --mem /GParted-Live-1.0.0-2.iso (0xff)
map --hook
kernel (0xff)/live/vmlinuz findiso=GParted-Live-1.0.0-2.iso edd=off boot=live locales=de_DE.UTF-8 keyboard-layouts=de gl_batch union=overlay username=user config components noswap ip= net.ifnames=0 nosplash
initrd (0xff)/live/initrd.img

BTW: I am using gparted-live-1.0.0-2-i686.iso.

Here I do not use grub4dos, but what I have tried is on Ubuntu 19.04, and the grub2 config is as in the previous post. It works successfully. Have you tried different versions of grub4dos? Or is it possible you can find a GNU/Linux distribution and try it?

Steven

5

Re: Boot parameter findiso is no longer recognized

Just for info.

The file gparted-live-1.0.0-2-i686.iso booted from MultiBoot-Stick with grub2 on it used on MSI Z370 GAMING PRO CARBON with i5-8400 works fine.
The file gparted-live-1.0.0-2-amd64.iso booted on the same hardware config works fine as well.

I'm using the grub2 config posted by Steven, just path to the file was changed:

menuentry "Gparted live - 1.0.0-2-i686 20190614" {
    echo Loading gparted-live-1.0.0-2-i686.iso live ...

    set isofile="/boot/iso/gparted-live-1.0.0-2-i686.iso"

    loopback loop $isofile
    linux (loop)/live/vmlinuz boot=live findiso=$isofile union=overlay username=user config components quiet noswap  ip= net.ifnames=0  nosplash
    initrd (loop)/live/initrd.img
}

Regards
cvbn

6

Re: Boot parameter findiso is no longer recognized

@cvbn,
Cool. Thanks for your confirmation.

Steven

7

Re: Boot parameter findiso is no longer recognized

Hi,

Debian Live 9.9 also works (you asked for testing other linux systems):

title debian-live-9.9.0-i386-lxde.iso
find --set-root /debian-live-9.9.0-i386-lxde.iso
map --heads=0 --sectors-per-track=0 /debian-live-9.9.0-i386-lxde.iso (0xff) || map --heads=0 --sectors-per-track=0 --mem /debian-live-9.9.0-i386-lxde.iso (0xff)
map --hook
kernel (0xff)/live/vmlinuz-4.9.0-9-686 findiso=debian-live-9.9.0-i386-lxde.iso edd=off boot=live components locales=de_DE.UTF-8 quiet splash
initrd (0xff)/live/initrd.img-4.9.0-9-686

As mentioned my usb-stick is formated with ntfs, since I want to use them under Windows too. Can this be the problem for GParted Live? Is there any debug-setting, which I can enable such that I see a more helpful message?