1 (edited by sunshineblind 2019-06-03 14:29:51)

Topic: please delete



Re: please delete

Using GParted's default MiB alignment will create partitions optimally aligned for you disk, which has a physical sector size of 4096 bytes.

I assume the message Optimal transfer size not a multiple of physical block size is only an information / warning message which is telling you that an optimal_io_size (0) is not valid and not a multiple physical_block_size (4096).

3 (edited by sunshineblind 2019-06-03 14:24:50)

Re: please delete



Re: please delete

(Please always provide the actual message rather than an edited copy of it.  I have now been able to find the source of the message and other references about it).

In short, yes MiB alignment is correct and 33553920 byte alignment is wrong.
Also you can ignore the warning.

That message is coming from the Linux kernel SCSI disk driver [1] and is just saying the kernel is ignoring the invalid optimal transfer size.  An optimal transfer size of 33553920 bytes (32 MiB - 512), which is not an exact multiple of the 4096 physical sector size, can't be correct.

[1] Linux 5.1 drivers/scsi/sd.c line 3101.

Googling for your error message finds this relevant article [2].  It tests I/O and finds MiB alignment to be correct.  It also identifies an external USB enclosure with USB-to-SATA controller as the source of the invalid alignment.

[2] Linux SSD partition alignment – problems with external USB-to-SATA controllers – II

5 (edited by sunshineblind 2019-06-03 14:24:57)

Re: please delete



Re: please delete

sunshineblind wrote:

so, if not mistaken, operating with gdisk would fix that parted 'error', right? - even though the misalignment can be ignored if you do not plan to attach that drive internally (sata III controller), later on?

i wonder if someone already tested with gdisk and can give a feedback?

You didn't used parted (the GNU Parted command line tool) and let it automatically choose partition alignment to create your partition.  Instead you said you used GParted (our tool, the GNOME Partition Editor) with the default MiB alignment.  Therefore you partition was create with the correct alignment.

You can confirm this by printing the partition table and confirming each partition starts on a multiple of MiBs and each partition ends on the sector before a next multiple of MiBs.

Use either or both of these commands:

parted /dev/sdc unit s print
gdisk -l /dev/sdc

7 (edited by sunshineblind 2019-06-03 14:25:06)

Re: please delete



Re: please delete

You don't seem to have understood the nature of the "Optimal transfer size 33553920 bytes not a multiple of physical block size (4096 bytes)" warning.  Even if you were to wipe your hard drive and have no partitions you will still get that warning.

The warning is only generated because:
1) you have the drive connected via a USB-to-SATA controller which is generating an invalid optimal transfer size for the disk; and
2) you have Linux kernel >= 5.1 which is reporting the fact the optimal transfer size is invalid.


Re: please delete

Unfortunately the O.P. (sunshineblind) deleted his posts in the thread, making harder to understand the problem.

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: please delete

I have copies of those posts.  Should I edit them and put them back?

11 (edited by gedakc 2019-06-04 20:33:24)

Re: please delete

If you still have the content of the posts, then I'd say go ahead and put the content back so that it is of benefit to other users.

Another option would be to create a summary post and consider making the topic sticky.

EDIT:  Based on JanC's response in IRC it seems better to create a new summary post.