1 (edited by Ob-iVan 2019-03-20 01:24:28)

Topic: Add packages to GParted live ISO

Good time of day!

I tried to create a modified GParted Live ISO based on version using this instruction, but encountered two issues when running the last command:

genisoimage -A 'GParted live CD' -f -r -hide-rr-moved -hide-joliet-trans-tbl -J -l -allow-limited-size -b syslinux/isolinux.bin -c syslinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -efi-boot EFI/images/efiboot.img -no-emul-boot ./ > /tmp/gparted-live.iso

First problem: when running this command under Debian 9 (in theory, this system should be native to GParted Live) I get the following error message:

genisoimage: unrecognized option '-efi-boot'
Usage: genisoimage [options] -o file directory ...

genisoimage version on this system is genisoimage 1.1.11 (Linux).

Theoretically, this problem can be solved by using genisoimage on CentOS 7 (although it is strange why the native genisoimage from Debian 9 is not suitable, especially considering the fact that CentOS 7 has genisoimage 1.1.11 (Linux) too).

But the second problem remains and cannot be solved so easily: the file EFI/images/efiboot file.img does not exist in GParted-live archive-0.33.0-1-i686-pae.zip. Really does not exist. Even the EFI/images/ directory is not there.

Tell me, please, what should I do?

Thank you in advance for your help!