1 (edited by tjleigh 2010-12-14 16:56:27)

Topic: [SOLVED] PXE boot won't download filesystem.squashfs

Hi, I'm new to PXE and amateurish with Linux. Having problems completing a PXE boot of GParted Live.

I did search the forums and google, read up as much as I could, but still having a problem.

Steps taken:

I downloaded gparted-live-0.7.0-4.zip from http://sourceforge.net/projects/gparted … e/0.7.0-4/

I set up my DHCP server (Windows 2008) to use pxelinux.0 as the boot file. This part is working

I set up tftp32 to serve the files from the zip. This part is working.

My pxelinux.cfg/default menu item options are:

kernel /live/vmlinuz1
append initrd=/live/initrd1.img boot=live config noswap noprompt fetch=tftp://

The vmlinuz1 and initrd1.img files are downloaded successfully.

GParted does request the filesystem.squashfs, and the first block is sent. But the tftp server never receives an ACK and so the download never continues or finishes.

Then I get some error after the Debian logo during boot about "unknown filesystem"

I also tried using http fetch but this doesn't work either (same problem - it doesn't fetch the entire file)

I have a feeling others may have had this problem, I just can't find any info to help me solve it... I'm sure it's just a missing option or badly configured pxelinux.cfg or something...

Thanks for your time smile


Re: [SOLVED] PXE boot won't download filesystem.squashfs

Ok... I used a (much) older version of tftpd (vesion 2.52) and it worked properly.

So put it down to buggy pxe support in tftpd.