1 (edited by zbrown111 2010-07-20 13:36:30)

Topic: [Solved] NTFS resize issue: NTFS volume size not fixed after PBR edit

I've experienced the NTFS resize issue and have followed the items in this post to attempt a fix:

I have a Dell Laptop w/ a small recovery partition and a WinXP partition consuming the rest of the drive (Drive is 80GB in total).  Tried to shrink main partition (/dev/sda2) and create another NTFS partition (/dev/sda3) for data storage.  Used gparted 0.5.1 from Knoppix live CD.  Gparted resized the partition, I rebooted and got the usual BSOD when booting into winXP.  I then did the following steps:

1. Boot into Knoppix live CD and obtained the fdisk and parted info below.

2. Obtained /dev/sda2 PBR with command:
dd if=/dev/sda of=sda-original.pbr bs=512 count=1 skip=192780

3. Copied sda-original.pbr to sda-current.pbr and used hexedit to make the following change:
00000020   00 00 00 00   80 00 80 00   A8 F3 4D 09   00 00 00 00

00000020   00 00 00 00   80 00 80 00   02 C5 E7 4F   00 00 00 00

4. Updated PBR with command:
dd if=sda-current.pbr of=/dev/sda bs=512 count=1 seek=192780

5.   Rebooted and got same BSOD when booting WinXP and gparted doesn't recognize my old winxp partition (/dev/sda2) after rebooting into Knoppix.

Gparted info screen says:
File system: unknown
Size: 22.18 GiB

First sector: 192780
Last Sector: 46717019
Total Sectors: 46524240

Unable to detect file system! Possible reasons are:
- The file system is damaged
-The file system is unknown to GParted
-There is no file system available (unformatted)

6. Used ntfsresize to get current volume info.  It looks like my PBR edits didn't fix the NTFS volume size issue.  Any suggestions for a next step?  Thanks much.

ntfsresize -f /dev/sda2
ntfsresize v2.0.0 (libntfs 10:0:0)
Device name: /dev/sda2
NTFNS volume version: 3.1
Cluster size: 4096 bytes
Current volume size: 686381728256 bytes (686382 MB)
Current device size: 23820410880 bytes (23821 MB)
ERROR: Current NTFS volume size is bigger than the device size!
Corrupt partition table or incorrect device partitioning

fdisk -u -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xdc0edc0e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      192779       96358+  de  Dell Utility
/dev/sda2          192780    46717019    23262120    7  HPFS/NTFS
/dev/sda3   *    46717020   156296384    54789682+   7  HPFS/NTFS

parted /dev/sda unit s print

Model: ATA WDC WD800BEVT-75 (scsi)
Disk /dev/sda: 156301488s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start      End         Size        Type     File system  Flags
1      63s        192779s     192717s     primary  fat16
2      192780s    46717019s   46524240s   primary         boot
3      46717020s  156296384s  109579365s  primary  ntfs

PBR files:

Any advice on a next step would be appreciated.  Thanks.


Re: [Solved] NTFS resize issue: NTFS volume size not fixed after PBR edit

You almost had the problem solved.  I think you only missed reversing the hexadecimal pairs.  smile

E.g., try:
00000020   00 00 00 00   80 00 80 00   4F E7 C5 02   00 00 00 00
instead of:
00000020   00 00 00 00   80 00 80 00   02 C5 E7 4F   00 00 00 00


Re: [Solved] NTFS resize issue: NTFS volume size not fixed after PBR edit

That was it.  I should have double-checked my hex pairs.  Thanks much. smile