1 (edited by oryan_dunn 2010-04-23 20:54:53)

Topic: Issue with moving partitions around with 0.5.2 live (and ntfs shrink b

My layout of my drive (/dev/sda) went something like this:

Partition   Type
1             NTFS
2             EXT3 (/boot)
3             SWAP
4             Extended (with lvm inside)

My goal was to reduce the ntfs and expand the extended partition.

I first tried to resize the NTFS and got the resize bug, but got that sorted out thanks to the tutorial posted here.

Then I tried to move the partition 2 and 3 up next to the NTFS, but then I got an error(sorry didn't write it down) and both my partitions 2 and 3 were shown next to the NTFS but as unknown types.  It seemed that any operation I tried afterwards failed with the "The kernel failed to re-read the partition table...." message.  Obviously, since my /boot with grub data was on it, I couldn't boot anymore.  I was able to do one operation at a time, to fix this issue.  No matter the operation, each would fail with the "The kernel failed ..." message.  I deleted both partitions 2 and 3 and created new partitions with the exact same sector size at the exact same location with the same partition type.  After all four operations were done (individually with a failure after each), I rebooted and everything was back to normal.

I downloaded the 0.4.5 release (which I've used in the past and didn't have trouble).  That was able to move both partitions and resize my extended partition without trouble.  It seems that the 0.5.2 release had some serious issues.

2 (edited by gedakc 2010-04-23 23:41:56)

Re: Issue with moving partitions around with 0.5.2 live (and ntfs shrink b

Which specific version of GParted Live did you use?
For instance 0.5.2-1 or perhaps 0.5.2-8?

Unfortunately I have not encountered this problem with my hardware and I have been using gparted 0.5.2 with parted-2.2 for quite a while.  Hence I will need help from you to try to determine the cause.

Does this problem occur each time you perform a resize?

What hardware are you using?
(E.g., motherboard, hard drive, etc.)

How is your disk device attached?
(E.g., SATA, IDE, USB, etc.)

The more I think about this, I believe the cause is that LVM is active which is causing all updates to the partition table to fail.  The same thing occurs if a partition is mounted.  Work is being performed upstream in the parted project to try to address this problem.

3 (edited by oryan_dunn 2010-04-24 00:53:27)

Re: Issue with moving partitions around with 0.5.2 live (and ntfs shrink b

This is on a Dell Latitude D620 laptop with an 80GB SATA hard drive.  The 0.5.2-1 live cd is the disk that all kinds of failures.  Moving back to the 0.4.5-2 (which I've used in the past on drives with LVM with success) worked.  After enlarging the extended partition, i created a new unformated partition within the extended partition.  Then I used Fedora 12 live with lvm to pull that into my lvm volgroup.

Since I got it all worked out, I don't want to mess around with anymore (I know, I can't help diagnose the cause).  The odd thing is that some updates were able to be performed as the first move (partition 2 up to the end of partition 1) failed, but the partition table thought that partition 2 had moved (when I rebooted, grub couldn't find the /boot partition). 

Just as a note, this laptop is a dual boot between WinXP and Centos 5.


Re: Issue with moving partitions around with 0.5.2 live (and ntfs shrink b

Thank you for providing additional information.  I have added the problem resizing with an active LVM to the following post:
WARNING! Problem Resizing File Systems with GParted