1 (edited by jesse 2010-04-15 15:03:01)

Topic: NTFS Resize Bug with systemrescuecd 1.5.1

I wanted to at-least create the thread, I will provide more detailed information tomorrow

Tested with the following software all from SystemRescueCD 1.5.1
GParted 0.5.2
Parted 2.2

Was able to replicate on 3 different sets of hardware using the same software configuration listed above

To reproduce I could restore the partition table manually using fdisk and recover the filesystem using partimage with an existing restore image

Reboot the system back into SystemRescueCD 1.5.1, launch gparted, resize the primary partition 10GB smaller (number used for testing) and create an empty primary ext2 partition in the empty space

Commit the changes, before clicking close to the dialog I could read through the commands run by GParted and it was clear in the one ntfsresize section that the command had resized the volume larger than the device

I could quickly resolve by re-creating the partition using the original partition size (which I had prior to the resize)
I could also quickly resolve by re-creating the partition to larger than the underlying NTFS filesystem (to clean the process I would grow the filesystem to the new device size)

I will follow the tutorial in the other thread and provide the information from the "WARNING! Problem Resizing File Systems with GParted" thread as soon as I can


fdisk -l -u

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3b2b3b2b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   467909189   233953571    7  HPFS/NTFS
/dev/sda2       467909190   488392064    10241437+  83  Linux
parted /dev/sda unit s print

Model: ATA ST3250318AS (scsi)
Disk /dev/sda: 488397168s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start       End         Size        Type     File system  Flags
 1      2048s       467909189s  467907142s  primary  ntfs         boot
 2      467909190s  488392064s  20482875s   primary  ext2

/dev/sda - MBR


/dev/sda1 - PBR


2 (edited by gedakc 2010-04-15 21:11:47)

Re: NTFS Resize Bug with systemrescuecd 1.5.1

Thank you jesse for providing a detailed report of this problem.

If you need some help to resolve your specific situation then just let me know.

In the meantime we will begin investigation to try to determine the cause of this problem.

If you have time, would you be able to test GParted Live 0.5.2-8 currently sitting in the gparted-live-testing branch with this same hardware?


Re: NTFS Resize Bug with systemrescuecd 1.5.1

I ran the following test using GParted Live 0.5.2-8 successfully

Restore hardware using SystemRescueCD 1.5.1 and partimage
Reboot and run through initial windows setup
Reboot into GParted Live 0.5.2-8 (previously would have rebooted into SysResCD 1.5.1 here)
Resized /dev/sda1 to be 10GB less, created ext2 partition in remaining space
Commit the changes

I ran through the test twice and both times it was successful, I did not capture parted or linux kernel version, I'm sure you have that information

I do want to note that I could not use mount -t cifs with additional options to mount a Windows share, seeing that GParted Live included partimage and seemingly supported mount -t cifs, this could be a quicker replacement to SystemRescueCD however it threw an error on mounting a read-only share. I did not look into the error any further however it did not work using the same command that did in SystemRescueCD

I also want to note that in two other test cases (different hardware) I used the Windows XP Pro installation media to install Windows, after the installation of Windows I ran through the same process using SystemRescueCD and had the issue, the XP Pro media is the HP included XP Pro reinstall for notebooks (installs like a retail copy of XP Pro)


Re: NTFS Resize Bug with systemrescuecd 1.5.1

Thank you jesse for running these extra tests.  The parted-2.2 version on sysresccd-1.5.1 contains some patches whereas the parted-2.2 on gparted-live-0.5.2-8 contains no patches.

To try to determine if these patches are involved in the problem would you be able to test with the Ubuntu 10.04 (Lucid Lynx) beta 2 release?

The "PC (Intel x86) desktop CD" Ubuntu release can be used as a live CD and also contains gparted-0.5.2 and a patched parted-2.2.

Your help to isolate the cause of this problem is greatly appreciated.


Re: NTFS Resize Bug with systemrescuecd 1.5.1

Over the past several days I have been running a test with 99,999 iterations to try to invoke the "failed to inform kernel of partition changes" problem.   This test did not encounter the problem.  Hence I will need more information to try to diagnose the problem that you experienced.

Were any partitions mounted when you performed the resizing actions?
Would you be able to test with the Ubuntu 10.04 (Lucid Lynx) beta 2 release?
Is there anything else you can think of that might help to troubleshoot this problem?