Topic: I'm the next: NTFS volume size is bigger than the device size

hi there,

iam the next one with this curious problem!

Yesterday I moved my Win7 partition because in front of it was a lot free space, and i wanted to create a new one in the end of der Harddisk.
So I decided to to use PartedMagic as a live version and I booted it from my Usb Stick.

I think near at the end the operation crashed and now my Windows fail to boot. ( I only moved the partition and havent resized it! )

I made a Screenshot to show you my Harddisk.

When I click on Information at sda7 the following message appears:
ERROR: Current NTFS volume size is bigger than the device size!
Current volume size: 52428796416 bytes ( 52429MB)
Current device size: 52427902464 bytes ( 52428MB)

Unable to read the contents of this file system!

As you can see, there is only 1MB difference between volume size and device size. So I hope there is no data loss or something.



Hope you can help me,

greetings from germany


Re: I'm the next: NTFS volume size is bigger than the device size

Which version of Partition Magic did you use?

Your data should still be intact.

Since the problem is with sda7 (as you indicated above), we will need to capture a copy of the NTFS Partition Boot Record from your sda7 partition.

You can capture the NTFS Partition Boot Record in a file with the following command:

NOTE:  Be extra careful to type this command in properly, otherwise loss of data could result.

dd if=/dev/sda of=sda7-bull.pbr bs=512 count=1 skip=274502718

where sda7-bull.pbr is the name of the file that will need to be uploaded.

Then upload this file to a media sharing site, such as mediafire, and post the link to this file in this forum post.

3 (edited by bull 2009-12-18 18:33:34)

Re: I'm the next: NTFS volume size is bigger than the device size

thanks for your post,

mh i tried to fix it myself, but it was not successfull.
i do not really know what ive done. I used TestDisk and used the quick search. Then i saw all my partitions and I clicked on Write and confirmed that.
Now i´ve rebooted and gparted shows that the hdd is now empty. No partitions, just empty.

I think i have to write the old mbr and pbr to the disk? That should work or?
How can i do this? I do not know which commands i have to use to write the mbr and pbr with my 2 backup files.

After that i will post the sda7.pbr

P.s. i think its 4.6 what im using. where can i look for that?
gparted is 0.4.8-git

Ok now, everything is like in post 1. I loaded my backup of the pbr and mbr which i´ve posted in the first post. now gparted shows the same like in post 1.
But something has changed, the error message in gparted has gone. I´ve made a check and there are no errors. But win7 still cannot boot.
i will post sda7.pbr soon.

ok here is my file now http://www.mediafire.com/file/no2znm2meji/sda7-bull.pbr

yay! win7 is running ! i thought when the error message in gparted does not appear, the partition is ok now.
so i tried to start win7, but error on starting: 0xc0000225
then i´ve inserted the win7 cd, booted, chose repair, and win7 fixed everything.
i think it was only the path of the partition that windows has changed.

im so happy that everything is working now!

thanks for your great support!

merry christmas and happy new year to all!

... damn my english....