Topic: gparted did make my xfs partition uselessly

hi all,

first: my english is not the best. but i hope you can understand my problem.

i wanted make larger my xfs partition for my vdr.
this is (WAS) my directory, for movies, music and many documents.

i downloaded the gparted-livecd.
first, gparted did not allow me to make larger the partition. i thought ok, i will move it to forward. because, i had space before it.
so, after many hours, gparted was finished, i make a reboot and the problem was there.
the xfs partition could not mount. ok, i tried this manuelly. but without access.

my restore procedures:
xfs_check - failed, because i can not mount it
xfs_repair - does not find die first superblock, after long searching the second too

ok next:
i found testdisk, in hope, this can help me. mistake.

so i downloaded systemrescuecd and i tried all tools which i found. but .... mistake ...

gparted can see that space is in use. but not more.
in this moment i am trying to move the partition (with gparted) to place on the old space. in hope it will works!

you are my last rescue!
can you help me!?


ps: maybe it is possible, dd move any bytes in the xfs partition without to lose data?


Re: gparted did make my xfs partition uselessly

modprobe xfs

You can't grow xfs without the kernel module being loaded and you can't mount it either.


Re: gparted did make my xfs partition uselessly


i can not mount xfs without xfs module (or builtin) too.
that i know.
that is not the problem. the 1. and 2. superblock does not exist!