1 (edited by m 2006-08-13 18:13:31)

Topic: [SOLVED] Newly enlarged FAT32 partition is shown as full

Ubuntu 6.06 up-to-date, external USB HD.

I just managed to resize a 40GB Fat32 partition after a bit of trouble (numerous sources state that for GParted to work, the volume has to be unmounted; but if I did so, it would not detect partitions and show the whole drive as unallocated).

So I deleted an old NTFS partition next to the one to be resized, created a new FAT32 one in its place (thought there was a 'merge' operation), deleted it again (had not been formatted), and resized the existing 40GB FAT32 to take up the 10GB of newly unallocated space.

So now I've got a 50GB partition which should have 10GB free space, but it doesn't.

Could someone explain to me what went wrong and how I can fix that?

Help and explanation greatly appreciated!



Re: [SOLVED] Newly enlarged FAT32 partition is shown as full

I found a hint to the solution in

For some reason the filesystem was not updated by GParted (maybe due to the fact that other partitions still were mounted at time of the changes, so reboot was recommended?), but fsck can fix it:

me@system:~$ fsck -r /dev/sda6
fsck 1.38 (30-Jun-2005)
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Free cluster summary wrong (14824 vs. really 670156)
1) Correct
2) Don't correct
? 1
Perform changes ? (y/n) y
/dev/sda6: 8772 files, 2605500/3275656 clusters


Re: [SOLVED] Newly enlarged FAT32 partition is shown as full

hmmz, what version of gparted did you use?