Topic: Scanning devices forever


I searched the forum for help on this problem and I saw the fix to disable the floopy (which I did) and I still have this problem.

Asus P4P800 P4 3.2Ghz
1Gb mem
160GB Western Digital (WD1600JB)
320GB Western Digital (WD3200JB)

Gparted Ver 0.3.1-1

I'm new to Linux so you might have to give me exact instructions on how to give you more info if you require it.



Re: Scanning devices forever

Well, the problem may come from the floppy, of course, but not surely.
Tell us about the fs of the partitions you have on your hd, please ?
If you do not know this info, just open a terminal from the livecd,
and type :
fdisk -ul
this will give the info.
If you could past it here, it would be great.
TO get this info :
type : fdisk -ul > slinger.txt
then plug a usb stick
type in the terminal :
fdisk -l | grep sd*
and see the device where the usb key is plugged (e.g. sda1)
thenon the term, type :
mkdir /tmp/usb
mount /dev/sda1 /tmp/usb
cp slinger.txt /tmp/usb
le /tmp/usb (here, you MUST see your file slinger.txt)
umount /tmp/usb
then unplug the usb key and open the file from another PC, and post the output.
thx smile

GParted-project Admin
Former GParted-LiveCD maintainer (2007)


Re: Scanning devices forever

Thanks for the reply, I just solved the problem.

My windows installation was all screwed up XP installed in G: for some reason and I was planning on formatting the drive and starting over but I wanted to test Gpartd first before I went ahead and did this.

After all these problems I just decided to format and then try it afterwards. I did this and now it works just fine. I extended my partition from 128GB to 320GB successfully.

In case you would like the info anyways, c: was NTFS d: was fat32 e: was NTFS.
C was one physical drive and D and E were another.



Re: Scanning devices forever

Hello, I've installed Kanotix 2006 RC4 which comes with Gparted version 0.3.1+cvs20060928-0+c0.kanotix.1.

I have the same problem of gparted scanning devices forever. I managed to install Kanotix on hard disk by creating a swap and an ext2 partition from within Windows XP with PQMagic and then installing Kanotix from live cd and using the Knoppix-installer.

My system is a Compaq Evo N610c laptop with P4 Mobile 1.67 Ghz and 30 GB hdd.

When I perform a fdisk -ul I get this:

Disk /dev/hda: 30.0 GB, 30005821440 bytes
240 heads, 63 sectors/track, 3876 cylinders, total 58605120 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1              63    18431279     9215608+   7  HPFS/NTFS
/dev/hda2        18431280    19459439      514080   82  Linux swap / Solaris
/dev/hda3   *    19459440    25613279     3076920   83  Linux
/dev/hda4        25613280    58605119    16495920    f  W95 Ext'd (LBA)
/dev/hda5        25613343    56503439    15445048+   7  HPFS/NTFS
/dev/hda6        56503503    58605119     1050808+   7  HPFS/NTFS

In the office I have installed the same Kanotix distro and Gparted is running fine. I even managed to schrink/resize the C: partition from Windows Xp with it.

Any help is welcome. Thanks in advance :-)


Re: Scanning devices forever

could you try tu run gparted in command line ?
open a terminal, and then type :
# gparted /dev/hda

and tell what happen then. THX

GParted-project Admin
Former GParted-LiveCD maintainer (2007)


Re: Scanning devices forever

Hi Larry, thanks alot for your answer. In the mean time I found out myself that this is a known bug by looking harder and going in the open bugs from bugzilla gparted.

So, I disabled the floppy from the BIOS as I don't have a floppy anyhow on my laptop and now gparted runs just fine. I did run it also from the commandline: gparted /dev/hda or gparted (without any argument) just works now.

This is great. I used to work with QTParted but since I updated my Kanotix distro qtparted has been replaced with gparted and this is a GREAT TOOL. Thanks to the developer(s) and thanks for your fast reply.

PS: I like your qoute ;-)


Re: Scanning devices forever

LarryT wrote:

Well, the problem may come from the floppy

Thank you thank you so much!!! I have spent a whole week solving a similar problem as Slinger had.

Recently I've upgraded my backup/media server with a new  HDD, The new HDD was not only larger, it had SATA interface instead of IDE, and here the fun started. I used clonezilla to copy the data to the new drive and the process ended without error. but the system failed to load (Opensuse 13.1 just stopped at the splash screen). The windows XP installer crashed as well.

I tried to wipe the drive, to make new clonezilla copies, to check the drive health with many different apps, to scan RAM for errors and even to reflash bios and nothing. So i concluded something is wrong with the MB and  decided to buy a PCIe to sata adapter (cheaper than a new pc)

the last thing i decided to do was to google for the symptoms, i started from the most annoying - the superlong GParted drive scan and found this thread.

As i discovered my no longer used  floppy drive was disconnected physically  but enabled in BIOS and this caused the whole pain. The problem could be resolved by disabling floppy in BIOS or by connecting it back. Thanks again!


Re: Scanning devices forever


I want to buy a scanner for my official work which must have a high scanning quality. Can you guys suggest me any such scanner?



Re: Scanning devices forever

Angled1952 wrote:


I want to buy a scanner for my official work which must have a high scanning quality. Can you guys suggest me any such scanner?


Sorry, GParted and the GParted forum aren't related to image scanning.

*** It is highly recommended to backup any important files before doing resize/move operations. ***