1 (edited by cmdr 2008-12-09 01:49:50)

Topic: [SOLVED] GParted Live 0.3.8-9 : Booting from USB key not possible


I just tried booting above mentioned testversion from usb key and failed, because "filesystem.squashfs" could not be found. Analyzing the problem with the help of "dmesg" and "live.log" resulted in a very special fault. My system (Win XP MCE, Dual Core Intel D 930, 3 GHz, 3GB RAM, 300 GB SATA, ATI Radeon X1600 Pro, 256MB, two ATA-CDROM/DVD drives) has a built in Flash Card Reader (MS/SD,CF,SM), which seemed to cause the problem.  CDROM drives (hda,hdb), SATA HDD (sda1-sda5), USB key(sdb1) and (empty!) Flash Card drives (sdc, sdd, sde) are detected, but "init" scans only "hda", "hdb", "sda","sdc", "sdd" and "sde" for "filesystem.squashfs", never "sdb(1)". Finally it stops and returns to console prompt "(initramfs)".

On a further test, I put the "/live" folder on a second USB key (sdf), starting with the first (sdb) ...  and  was successfully booting "GParted".  I could nevertheless not use it, because support for my PS/2 mouse seems to lack on the new version ( USB mouse fortunately works !). With my "good old 0.3.4-11" I even could work "stereotactical" with the two mice !

What you surely already know, is, that two of the "idesktop" icons do not work anymore (since 0.3.7-7, if I'm not wrong): USB and INFO. It's a minor issue (and a simple fault: "mlterm" needs "-e" as parameter), but as it is obvious, that "GParted" is more and more used by Linux newbees, it should work as expected to ease their work ( and to ease support !).  BTW, I'm working on that issue in my spare time, using "Xdialog" in my program on all user interactions and  implementing its progress bar on all time consuming processes. I'll be ready soon. Who is the maintainer for this ? LarryT or Steven Shiau ?



Re: [SOLVED] GParted Live 0.3.8-9 : Booting from USB key not possible

Hi cmdr,
I am Steven, maintainer of GParted live. Thanks for your tests and reports.
As for your booting problem and PS/2 mouse, I will do more test tomorrow in my office to see why live-initramfs skips /dev/sdb and why no support for PS/2.
About the icon USB, I think maybe it does not fit the current gparted live, so I am thinking about removing that. If your xdialog one is better and fit the current GParted live USB, definitely we should use yours.
About "INFO", I did not see any problem here, what's the error messages ?
Thanks again.


Re: [SOLVED] GParted Live 0.3.8-9 : Booting from USB key not possible

Hi Steven,

with my oldest (and probably slowest) USB key, I managed to start "GParted 0.3.8-9" repeatedly now. PS/2-mouse is working, Info-Button also. But with the two sticks, I used before, the written problems still exist and are reproduceable. I did file comparisons, but could not see any differences. One stick is booted by "syslinux", the other by "GRUB4DOS" (as does the one, which works). On all sticks are several other programs (Puppy Linux, PartedMagic, SliTaz, older versions of GParted; the latter separated in folders of their own), which boot and work fine with my system.



Re: [SOLVED] GParted Live 0.3.8-9 : Booting from USB key not possible

USB stick booting sometimes is annoying... For syslinux, it's different to grub.
I updated http://gparted.sourceforge.net/liveusb.php, you might make sure:
# Some of USB flash drive does not contain any booting program in the MBR. If so, it won't be able to boot. You can run "cat /usr/lib/syslinux/mbr.bin > /dev/sdb" (/usr/lib/syslinux/mbr.bin comes with package syslinux). The path of the mbr.bin depends on the GNU/Linux distributions. WARNING! Executing it incorrectly could cause your GNU/Linux not to boot. Confirm the command before you run it.
# If your USB flash drive is not able to boot, check (1) Is there any partition in your flash drive ? It must contain 1 partition at least. (2) The partition must be marked as "bootable" in the partition table. (3) The partition must be on the cylinder boundary.

5 (edited by cmdr 2008-09-29 02:10:12)

Re: [SOLVED] GParted Live 0.3.8-9 : Booting from USB key not possible

Hi Steven,
thanks for your reply ! As I'm very familiar with HDD structures (MBR,PBR,VBR), I checked before posting here, whether my USB sticks are bootable at all. I'm even able to make virtually any USB stick bootable with nothing but a HexEditor. It's proven, that they boot, because there are up to five other Linux programs on each stick, which boot fine, as I already mentioned.

Examining "dmesg", I found an irregular pattern, concerning the detection of the involved USB Stick :

[   10.425405] sd 2:0:0:0: [sdb] 1002496 512-byte hardware sectors (513 MB)
[   10.439371] scsi 3:0:0:0: Direct-Access     Generic  Flash HS-CF      4.52 PQ: 0 ANSI: 0
[   10.454433] sd 2:0:0:0: [sdb] Write Protect is off
[   10.468176] sd 2:0:0:0: [sdb] Mode Sense: 43 00 00 00
[   10.468179] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[   10.482630] sdb:<5>scsi 3:0:0:1: Direct-Access     Generic  Flash HS-MS/SD   4.52 PQ: 0 ANSI: 0
[   10.535027] sdb1
[   10.535122] sd 2:0:0:0: [sdb] Attached SCSI removable disk

Last three lines should probably look like this :
[   10.482630] sdb: sdb1
[   10.535...] scsi 3:0:0:1: Direct-Access     Generic  Flash HS-MS/SD   4.52 PQ: 0 ANSI: 0
[   10.535122] sd 2:0:0:0: [sdb] Attached SCSI removable disk

Perhaps it's a timing problem (sdb1 needs a pause for settling ) ?



"filesystem.squashfs" could not be found, because I did not use standard folder "live", but renamed
it to "live8", which doesn't matter for kernel and initrd, but for the squashfile.  I analyzed "initrd1"-Image and found out, that the squashfile has to be by default in "live"-folder, unless you specify another location with parameter "live-media-path". To use "live-media-path=live8" was the solution and it worked fine from now on !

In addition to that, I tried parameter "live-media"  resp.  "bootfrom" (synonym) to get "GParted" work from an USB-Stick on an older Laptop,  which cannot boot from USB and it worked, too !.
Parameter was "bootfrom=/dev/sd".  Kernel and initrd-image have of course to be on the laptop's HDD with a Linux Bootmanager, to achieve this. If the same version is installed both on the HDD and the stick , furthermore the storage folders are synonym on stick and HDD, "bootfrom" is disregarded and "GParted" works from HDD. I think, that the search is aborted, if squashfile is found, and that the HDD has simply the higher rank in search sequence or is quicker. If you use different folder names, "bootfrom" works of course as expected !