Topic: I screwed up - and I need your help

Good day. I wanted to remove two old linux partitions that were on the same drive with my two Windows partitions (one was an old windows installation, just the system drive, no boot/recovery cuz I removed them and the other one was a regular file storage drive). Diskmgmt and diskpart couldn't remove those partitions, so I removed them with the help of gparted. Then I rebooted to Windows, and it indeed made the space unassigned. Then I tried to extend the first partition to to the left where the linux partitions were previously at with diskmgmt, but there 'was not enough free space' so I thought why not try make gparted do it.
It is worth noting that they both looked like one partition with the size equal to that of the whole disk which is 2 TB.
I thought it wouldn't matter cause I just move it to the left, so I waited for ~18 hours for it to complete and when I loaded back into Windows, those two drives didn't have size bars (I will hopefully be able to post a screenshot as a reply, only one link is allowed per post it seems).
And when I tried to click on one, it said that I would have to format it first to use it. When I clicked 'Cancel', I was told that I had no access to the drive because Windows wasn't able to identify the file system. On diskmgmt the partition structure looks the same, 100 gig of unallocated space and two drives, but now they're RAW and green, before they were NTFS and blue.
I suspect that gparted just moved the contents to the left and didn't make necessary changes to the partition table itself that Windows would understand or something like that. Also for some reason the whole drive now appears dynamic (maybe it was dynamic before, but I doubt it) which is probably not a good thing either.
I am sure it can be restored, but I don't have enough expertise to do that so I hope to get help.


Re: I screwed up - and I need your help

Here's the screenshot of how those drives look in explorer.

3 (edited by Wolterhon 2024-02-04 12:26:41)

Re: I screwed up - and I need your help

A significant update: I've confirmed that the files are still there (at least from the D drive), they are accessible through PopOS that I've booted to from a thumb drive. Now I gotta find the E drive files lol.

4 (edited by Wolterhon 2024-02-09 16:56:32)

Re: I screwed up - and I need your help

Another update: I've performed a deep scan of the drive through TestDisk (while on PopOS), and it has found the third partition. For some reason there are two almost identical partitions, one is described as just NTFS, and the other one is something like 'NTFS from recovery sector'. Also their respective starting and ending sectors differ by about a million and one of them has a bigger size in sectors even though they both have the same capacity which is 487 Gb.