1 (edited by cstn 2021-07-08 00:28:48)

Topic: [SOLVED]GParted v1.3.0 cannot list mmcblk(emmc) device

my laptop shipped with an emmc storage chip on mainboard and a sata ssd drive.

today I suddenly noticed GParted v1.3.0 cannot list my emmc device, only a /dev/sda in the "Devices" menu.

only when I started GParted like this in terminal, it will find my emmc(mmcblk0) device:

[tom@testlaptop ~]$ gparted /dev/mmcblk0

but only mmcblk0 there, /dev/sda will lost in "Devices" menu.

I tried GParted v.1.1.0, it can list both /dev/mmcblk0 and /dev/sda in the "Devices" menu.

My system is Archlinux with software updated.

So, why the new GParted  version lost my emmc device? how to fix that?


Re: [SOLVED]GParted v1.3.0 cannot list mmcblk(emmc) device

The lack of auto recognition of devices names like /dev/mmcblk# is a regression that was introduced in GParted 1.3.0.

See Merge Request !83 - Fix recognition of SD/MMC device names.

Until the next release comes out, the work around is to either pass the device paths to gparted on the command line, or to use an earlier release such as GParted 1.2.0.


Re: [SOLVED]GParted v1.3.0 cannot list mmcblk(emmc) device

@gedakc Thanks ! It's glad to know this bug will be fixed in the next version.