Topic: GParted Live cannot boot from PXE

In the past I had a very old version of Gparted Live which can boot using network/PXE. But with the new version (1.1.0-8-i686) I can't get it to work. It loads the kernel (vmlinuz) and initrd just fine, but fails to mount the Squashfs.


I'm then dropped to a BusyBox shell and I can't ping to the server by IP-address, it just say "Network is unreachable". But I'm sure the server is online because it just loaded the vmlinuz/initrd from it...

This PC has a Realtek network card, but I tried a PC with Intel network card which gives the same problem.


Re: GParted Live cannot boot from PXE

I followed the instructions on the webpage and used these lines in pxelinux.cfg to boot Gparted Live:

LABEL GParted Live 1.1.0-8-i686
KERNEL gparted-live-1.1.0-8-i686/vmlinuz
APPEND initrd=gparted-live-1.1.0-8-i686/initrd.img boot=live config components union=overlay username=user noswap noeject ip= vga=788 fetch=

I've already checked the webserver URL which is correct (I can download the file).

(I post it in two posts because otherwise the forum is saying "Too much links in message. Allowed 1 links.")


Re: GParted Live cannot boot from PXE

It looks like this PXE client did not get an IP address from DHCP server. Are you sure the DHCP server in the LAN is running?
Or maybe it is denied by the server?
Another possibility is somehow the network card starts too later so it's not able to connect to the LAN.
How about giving testing GParted live 1.1.0-9-amd64 a try?



Re: GParted Live cannot boot from PXE

BTW, when it fails, in the busybox shell you can try to run "ip add show" to list the IP address, and "ip route show" to check the gateway. Make sure this client has leased an IP address from DHCP server.


5 (edited by Fientje 2021-01-11 16:58:19)

Re: GParted Live cannot boot from PXE

The DHCP server is running and the PXE boot ROM can get an IP address, that's why it can load the vmlinuz and initrd. But when the kernel is loaded, it doesn't have an IP address anymore.

I found out the problem lies in the "ip=" parameter. If I remove this parameter then it will get an IP address and booting works fine.

I've tried ip=dhcp as well, but that doesn't work. Only removing the whole ip= parameter works.

I think it should be corrected in the instructions here (https://gparted.org/livepxe.php) which mention the ip= parameter.


Re: GParted Live cannot boot from PXE

Oh, yes. That's the culprit. I have updated that webpage.
Thank you very much.