Topic: GParted boot fails: "AHCI controller unavailable"

I've used Gparted from inside Linux, and live on USB and optical disk too, for some time. My old trusty machine boots the live media just fine. I built a  nice new Ryzen 7 3700X machine with MSI X570-Pro BIOS. I have disabled secure boot, and set SATA Mode to [AHCI Mode]. I boot into either the dvd or the usb and get the graphical window, hit enter or elect an option, then it goes to the console like expected, thinks a while, then fails with this message:

AHCI controller unavailable

I have tried safe mode and several other options in addition to just selecting the normal way. Maybe someone has seen this error before. Any clues would be appreciated.

Right now I have a dual-boot on the machine with Windows 10 and FreeBSD 13.0 Current. I use Rod Smith's Refind boot manager. All this works with the BIOS just fine, but since I almost weekly wipe & load the weekly FreeBSD 13.0 Current snapshot, GParted can be a big help.

Thanks, Clay Daniels.


Re: GParted boot fails: "AHCI controller unavailable"

May be @stevenshiau can help with booting GParted Live CD issues.

As an alternative System Rescue CD includes an almost up to date copy of GParted and you could try booting from that instead.


Re: GParted boot fails: "AHCI controller unavailable"

Thanks for the suggestion about the System Rescue CD. I downloaded it, burned it to a bootable cd/dvd. On my old machine it boots, like GParted live does, and has some interesting options, which I played with a bit. On the new machine it gave the same boot error, "AHCI controller unavailable".

The problem is NOT GParted, it is the BIOS settings on my new machine. I even did a BIOS update yesterday. My new machine's BIOS is a lot more complex than my trusty old 2014 HP Pavilion All-In-One. I had all the settings figured out there by now, what few there are. The new machine is a learning curve. I will just keep at it. I have the AHCI mode enabled & secure boot disabled. I'm still searching for what Microsoft calls "Fast Boot" so I can disable that too.

Meanwhile, there is really no problem. I installed a new M.2 drive and now can use one drive to work on the partitions of the other. The wonderful thing about GParted live is that you are working independent of the drive, not from one of it's partitions. It's a real game changer when you can totally wipe a drive clean, re-partition, & format a new layout to install what you want, where you want it. So I'm not giving up on GParted.



Re: GParted boot fails: "AHCI controller unavailable"

So after you upgraded your BIOS, is your issue solved?
If not, which version of GParted live did you use? Have you tried the latest one 1.0.0-5?



Re: GParted boot fails: "AHCI controller unavailable"

Steven, the BIOS upgrade did not solve the problem. I was using versions 1.0.0-1 & 1.0.0-4, but I just now downloaded the latest GParted version 1.0.0-5 and burned it to a disk. It worked great on my older 2014 HP machine where I have Windows & MX Linux installed, but the new machine which is a self-built Ryzen 7 3700X with MSI X570-A Pro motherboard gives the same error, "AHCI controller unavailable".

With the new machine I have been able to load Windows 10 and FreeBSD operating systems. GParted loads, gives the graphical screen with the disks and a menu, which I can select and hit enter to go to the console. That's where I get the error and it will go no further.

I think my problem is some BIOS setting. The new BIOS is quite advanced compared to the old 2014 machine, almost a mini operating system in itself. I keep reading the MSI manual and doing trial & error. I will eventually get this figured out, but was hoping someone might give me some clues, perhaps even had the same problem.



Re: GParted boot fails: "AHCI controller unavailable"

Not sure if this helps. I uploaded a newer GParted live  1.0.0-6 with slightly updated Linux kernel 5.2.17-1:
https://sourceforge.net/projects/gparte … g/1.0.0-6/
Please try it. If it does not help, maybe you have to wait for newer Linux kernel available on Debian Sid repository so that we can create another GParted live.



Re: GParted boot fails: "AHCI controller unavailable"

Steven, thanks for all your help, but still no go here, same message: "AHCI controller unavailable!". The problem is not GParted, but something on my end. If I look from my M.2 drive (nvd0) where I have FreeBSD installed, I can run the command line version, gpart, with these results:

clay@r7bsd:~ $ gpart show -p
=>        34  3907029101    ada0  GPT  (1.8T)
          34        2014          - free -  (1.0M)
        2048     1083392  ada0p1  ms-recovery  (529M)
     1085440      204800  ada0p2  efi  (100M)
     1290240       32768  ada0p3  ms-reserved  (16M)
     1323008  1072420864  ada0p4  ms-basic-data  (511G)
  1073743872  1073743872  ada0p5  linux-data  (512G)
  2147487744  1759541391          - free -  (839G)

=>        40  2000409184    nvd0  GPT  (954G)
          40      532480  nvd0p1  efi  (260M)
      532520  1991761920  nvd0p2  freebsd-ufs  (950G)
  1992294440     8114784  nvd0p3  freebsd-swap  (3.9G)

=>        34  3907029101    diskid/DISK-ZFL0FRH4  GPT  (1.8T)
          34        2014                          - free -  (1.0M)
        2048     1083392  diskid/DISK-ZFL0FRH4p1  ms-recovery  (529M)
     1085440      204800  diskid/DISK-ZFL0FRH4p2  efi  (100M)
     1290240       32768  diskid/DISK-ZFL0FRH4p3  ms-reserved  (16M)
     1323008  1072420864  diskid/DISK-ZFL0FRH4p4  ms-basic-data  (511G)
  1073743872  1073743872  diskid/DISK-ZFL0FRH4p5  linux-data  (512G)
  2147487744  1759541391                          - free -  (839G)

clay@r7bsd:~ $


Re: GParted boot fails: "AHCI controller unavailable"

Not sure... If this is Linux kernel related, then you have to wait for newer Linux kernel available on Debian Sid repository. Once it's available, we will create another GParted live if you need that.