Topic: [SOLVED] Cannot build gparted 1.0.0 on Linux Mint

I'm trying to build v1.0.0 from source and I'm stuck in configure with error:

checking for ped_device_read in -lparted... no
configure: error: *** libparted not found.

I am on linux mint cinnamon machine and libparted2 v3.2 is installed, but seems that configure script doesn't find it. I tried to symlink libparted.so.2 to libparted.so, but then configure throws this error:

checking for libparted >= 2.2 (querying pkg-config)... not found
checking for libparted >= 2.2 (querying libparted)... configure: error: *** Error querying libparted version.  Check config.log for details.

which isn't right because libparted version is >2.2


Re: [SOLVED] Cannot build gparted 1.0.0 on Linux Mint

Make sure libparted-dev package is installed.

sudo apt-get install libparted-dev

N.B.  This is mentioned in the README file.

3 (edited by danzax69 2019-05-31 23:15:35)

Re: [SOLVED] Cannot build gparted 1.0.0 on Linux Mint

I'm trying to do it, but I get dependency conficts, with libbkid and libdevmapper-dev.
I have some newer versions from unofficial ppa. I've manage to downgrade them and finally install libparted-dev.