Topic: problem making live USB of Gparted 0.30

New Thinkpad X1. I want to repartition the drive before installing debian. It's made to boot instantly into Win10 if it doesn't recognize bootable media.

That means I can't try any of the options listed in Appendix B. Instead of giving me a boot options menu, it goes straight to the Win10 whirligig thing and I have to do a hard reset to get out of that.

I've tried tuxboot 0.6, several times. A web search showed that has some kind of longstanding bug making gparted liveUSB. So then I even tried unetbootin, but same story.

I could burn to an actual CD if that might help. ???

Any suggestions / workarounds much appreciated!


Re: problem making live USB of Gparted 0.30

The "Appendix B" of the "GParted Live Manual" is related to How to boot from the bootable medium in case of problem concerning the graphics firmware of the computer.
Creating the bootable medium is discussed in the page "GParted Live on USB".

Perhaps you can check your USB on another computer, preferably using some o.s. other than windows 10, to see if it is well prepared. Furthermore, if the computer's firmware is UEFI, you can try to deactivate the "secure boot" option from the Setup menu.

To enter to the setup menu, you have usually to repeatedly press a specific key on reboot; you can know this key from the computer's manual. This key was F1 or F2 in Lenovo computers. However it is possible that your computer doesn't use anymore that tip, as many laptops that come with windows 8 to 10 preinstalled. In this case, booting into an external medium is generally made from within the o.s. Please, look at that page where another method is described:
How to enter BIOS setup ob Lenovo laptop (applying to Windows 10/8.1/8)

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: problem making live USB of Gparted 0.30

Thanks for the answers!  I've had all kinds of boot problems and gradually realized they were all due to the UEFI boot. I think liveUSBs (at least in the Linux world?) tend to assume that you can use MBR if you want.

However, if I set the BIOS to boot UEFI + Legacy then it won't boot at all. So it has to be UEFI only. No idea why. I do have Secure Boot turned off.

In terms of booting the Debian OS itself, I wound up using rEFInd. I couldn't get grub-efi to work.

I did check the USB stick and all the rest of it (there are about 10 laptops around the house big_smile), but none of that is the problem.

The problem is to figure out how to get an install of gparted on a liveUSB that boots. Maybe try it as part of Puppy Linux or something??


Re: problem making live USB of Gparted 0.30

If the USB stick can boot on other computers, I think the problem is to the computer/firmware side.

Are you able to boot any other live cds or USB drives on this computer?
If yes, you can use GParted from "System Rescue CD". It contains GParted along with many other system tools. It is better to use such a bootable tool instead of Puppy or other general purpose Linux distibutions, because these distributions usually contain older GParted versions.

If no, there is probably some strange firmware setting to fix.
Unfortunately the firmware interface and settings aren't standardized in the UEFI specification.

For more deatils, you can look in this article, accessible from the Documentation page of the GParted web site. It is quite long and gives useful info.

*** It is highly recommended to backup any important files before doing resize/move operations. ***


Re: problem making live USB of Gparted 0.30

Thanks for that! Life happened and I forgot about this thread for a while. I'll try that System Rescue CD. I vaguely remembered something like that, but couldn't remember what it was called. And the Goog only works if you know most of the answer already.

Anyway, I'll report back how things go.

Oh, and, yes, I got Debian installed using a USB drive. Clonezilla booted via thumbdrive, the rEFInd install/repair utility booted. So quite a few things. It's just the gparted that seems fussy.