1 (edited by McCoy-Tyner 2018-01-28 09:12:30)

Topic: SOLVED: PXE-Boot issue

Dear listmembers,
when booting gparted (0.30 from last October, the version prior to this behaves identical) from PXE, I end up with the following message on the left top corner of a text - screen:

Debian GNU/Linux buster/sid debian tty1
debian login: --noclear (automatic login)

flashing every say 5 seconds.

The boot - commandline on the PXE - server looks as follows:

# boot gparted
label gparted
   menu label GParted Live 0.30
   kernel gparted/vmlinuz
   append initrd=gparted/initrd.img boot=live union=overlay config locales=de_DE.UTF-8 keyboard-layouts=de gl_batch genoswap noprompt  vga=788 fetch=tftp://

Now, if I remove the "gl_batch" from the commandline and press "2" at the end of the boot process to enter a shell, I get the shell. After that, I can type "startx", X11 is starting flawlessly and a right click on the mouse brings up a menu where I can start gparted from. So, I basically got what I needed, however, for a not knowledgeable person this might lead to problems.

Therefore I would kindly ask whether someone has an idea what could have gone wrong and whether or not I can test something in order to help solve this issue - without knowing I had had expected gparted to start without user interaction. However, I have to admit that I did not try anything but the PXE-boot variant as my Laptop I requrired it for only boots from PXE for several reasons.

Thank you very much in advance

Dieter Jurzitza


Re: SOLVED: PXE-Boot issue

As described here:
Please add "username=user" to your boot parameters.



Re: SOLVED: PXE-Boot issue

Hello Steven,
thank you so much. I found the solution by myself in the meantime, however not actually knowing what the root cause of the failure was. Nevertheless, using:

append initrd=gparted/initrd.img boot=live config components union=overlay username=user locales=de_DE.UTF-8 keyboard-layouts=de gl_batch noswap noeject ip= vga=788 fetch=tftp://

made things work. I found someone relating to the identical issue within the forum, and the solution was identical to the one you suggested - I had had used the wrong parameters for searching at the very begin.

Take care, your help was highly appreciated,

Dieter Jurzitza


Re: SOLVED: PXE-Boot issue

No problem. Enjoy GParted!