1 (edited by BlueDragon 2017-02-28 06:19:27)

Topic: [Solved] GParted Live from USB with UEFI Freezing with Errors


I've been trying for several hours to have GParted Live booting from USB on my new UEFI board (Z97 Chipset).

First problem I had to solve was to find a working setup (from Windows) for the USB stick. After I lost hours trying with Method A, B and so on (Tuxbot, Makeboot.bat and others) finally I found a quick and efficient way with Rufus v.2.12. I'd suggest to add this on the website page as Method A (easy, fast and working).

Now whichever GParted Live iso version I tried so far, I could never have it run passed the first UEFI boot menu step. Seems the problem is really related to the content of the iso. I'm rather a beginner in the nix world so I simply tried all I could but abandoned on this one now. I could find a "half solution" by using the latest SystemRescueCD which now is booting perfectly well from the USB stick in the UEFI mode. This one was also not straight forward since there is also a bug / mistake in the grub configuration file, which must be edited manually, otherwise it's not booting at all (not finding the linux kernel). Here I could find the solution to this problem: edit the following file \boot\grub\grub-380.cfg and replace every instance of “isolinux” with “syslinux”. Drawback is that it's by far not the newest version of GParted.

I tried several of the latest GParted iso versions (28.1.1, 28.0.1, 28.0.0, 27.0.0) including the latest beta, for 64 and for 32bit systems. All are more or less leading to the same error:

After the log entry "[sdg] Assuming drive cache: write through" the system seems to hang for around 30 sec before a bunch of errors are displayed: ... "ata7.00 exception Emask 0x52 SAct .... frozen" "SError ... failed command: IDENTIFY PACKET DEVICE ... (ATA bus error)... and finally hanging totally after "ata7.00: status: { DRDY}"

Tried with several other boot modes (failsafe, vga etc.) but nothing did the trick. I also read what was said about checking BIOS settings (SecureBoot not activated) and graphic cards but that did not help neither. I assume the problem is not the video adapter (AMD Radeon HD 6450).

Somehow I get the feeling that I can't be the only one with this problem...

Any hints?



Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Are you able to boot other GNU/Linux distributions from live media?

For example Debian, Ubuntu, or Fedora?

3 (edited by BlueDragon 2017-02-22 20:01:04)

Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Hi gedakc,

I'll test that (from USB) and let you know soon.


EDIT: Well actually (my night was too short) of course I could boot successfully other linux live versions from USB. I just installed Mageia 5.1 this way. But it was over the installation iso file, not the live-cd iso one. That does not matter though I guess, for what you want to know, right?


Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Can you test with the latest version of Debian Live?

GParted Live is based on Debian Live (SID).


Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Yes, sure I will do that as soon as I can and post the results.

Meanwhile I continue to "experiment" (was not the real aim but just became like that obviously) with UEFI and booting Linux Mageia 5.1. Last situation is that now I can't boot in my BIOS at all (Gigabyte GA-Z97-D3H). Mageia is booting lightning fast (something like less than 10s) BUT it's the only thing I can do now anymore. Not any way left to access BIOS nor even to change the boot options within the Mageia boot loader (menu at the very beginning). Seems like I will have to shortcut the CMOS pins... (I setup the BIOS for ultra fast booting because the normal one was very slow.) or to unplug AC for forcing the BIOS to go back to normal booting speed... Anyway, total mess so far! hmm

Will report back later once I know more.



Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

There should be some way to access the BIOS again.  Some Internet searches or reading the motherboard manual should lead to an answer.

Unable to access bios after enabling Ultra Fast Boot


Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Hi gedakc,

Thank you very much for the link and your support. Meanwhile I could find the time to sort out what was needed by reading and testing. The solution was twofold:

1) No BIOS access anymore because of this (stupid) "ultra fast" boot option in the Gigabyte BIOS: Solution was to cut the AC power while the system was running somehow. Best of course is to do it just after starting it for instance. Thus the BIOS setting for Fast Boot is falling back to "Normal" or "Fast" but not "Ultra Fast". If this feature would be a minimum documented somewhere, which is clearly not at all the case (like most of the BIOS settings anyway, be it ASUS, Gigabyte or any other manufacturer who is not givin a damn about it), then it would not be such a hassle. For those interested. The speed difference between Ultra Fast and Fast is almost nothing (at best 1-2 seconds) with my system configuration. The biggest difference is the option to boot in BIOS (with 'del' or F12 (indirectly) or not at all. Solution can also be to shortcut the CMOS pins of course, but it's not needed if once is applying the method I just described above.

2) Error while booting Linux: This one was quite tricky and again twofold basically. First error still happening right now (don't know exactly why, maybe because of the mounting of an NTFS partition one suggested, have to dig deeper), is not preventing the boot process. The second error which was after a while totally stopping the boot process, was due to a shitty and messy Asmedia SATA controller card (PCIe). I had only troubles with this card (probably the chipset) at every level, with Windows XP, with my former Asus Board and another chipset too. Should have been thinking about it earlier. It's the ATA error message during the boot process which lead me to finally think about it. Could also have been the video card but it was not. So I just kicked this Asmedia card out of my big tower case and since then everything is smooth like silk (besides this error message above, but I will look at it later, obviously it's only a cosmetic thing). "Funny" thing was of course that while I was testing the GParted live boot from USB, it went wrong (total coincidence) several times whereas with Mageia it booted just ok (but also not every time, I noticed later on). Was depending on cold or hot reboot at a given time, amongst others.

So now everything is ok, Gparted can boot with the latest Beta version in UEFA mode from USB stick. As I wrote previously, I really liked Rufus the best for creating very easily and quickly the needed boot files on the USB stick. I would suggest you to add it to your wiki page (after having tried yourself, just to be sure).

Thanks again for all and this great tool!!


Re: [Solved] GParted Live from USB with UEFI Freezing with Errors

Thank you for reporting back with how you resolved the issue.

If you wish to help others searching for answers to similar questions, then you can edit the initial post and prefix "SOLVED" in front of the title.

We are glad to learn that Rufus worked well for you.  There are many different ways to write bootable images to USB flash drives.  The one we support directly is TuxBoot as it is maintained by the team that also maintains Clonezilla.