Topic: UFS Support

UFS has been supported for some time with the ufsutils package, at least in Debian releases (version 8.2-3 in Ubuntu).
It contains:
* mkfs.ufs
* fsck.ufs
* fsdb.ufs
* dumpfs.ufs
* growfs.ufs
* tunefs.ufs
* badsect.ufs
* ffsinfo

It supports FFS, UFS, and UFS2.
Isn't it about time GParted properly support UFS through this package?


Re: UFS Support

Thank you atescomp for bringing the ufsutils package to our attention.

The ufsutils package appears to have a interesting history.  Ufsutils v8.2-3 exists for Debian 7 Wheezy, but there is no package for Debian 8 Jessie (current stable release).  Further there now appears to be a ufsutils v10.1~svn272500-1 for Debian Sid (unstable).

From looking at the ufsutils Debian Package Tracking System under NEW, it says:

[2015-04-27] ufsutils REMOVED from testing (Britney)

Unfortunately I did not observe a reason why the package was removed, and also why the package does not exist in Debian Jessie.

I suspect there were issues with either the source code or the licensing, but I do not know for sure.


Re: UFS Support

Thanks for the reply.

The Debian package maintainers seem to be confused.  While it's an s390 arch, they clearly had Jessie package support at one time from this remnant:

Launchpad documents support in Jessie as the same version for Sid as show here:
Tracking the publishing history in Launchpad shows that Jessie has copied from Sid since 8.2-3

There are a couple of minor patches that seem to have been applied to correct a few bugs.  It may have gotten lost in the fog.  The package looks like it needs a little love from someone to get it back on track.  BSD licensing does not seem to be an issue as documented in the copyright file:

Redistribution and use in source and binary forms, with or without modification, are permitted under the terms of the BSD License.


Re: UFS Support


I am satisfied that ufsutils is derived from *BSD and is under a BSD license so can be included in GParted Live CD.  I have tried to install ufsutils on these three distros:

  • Debian 8

  • Ubuntu 14.04 LTS

  • Ubuntu 15.10

but they all fail like this:

$ sudo apt-get install ufsutils
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ufsutils

If you can tell me how to resolve this I can look at updating the GParted app to make use of the commands in ufsutils.



Re: UFS Support

From looking through the ufsutils bug reports it would appear that ufsutils contains many problems and is not actively maintained.

See Debian Bug report logs - #735041 -- ufsutils: now only for kfreebsd-any?

My guess is the major distros are avoiding ufsutils due to these issues.


Re: UFS Support

While Debian considers the ufsutils package not suitable for distributing we can't add it to the Live CD or add greater UFS support to the GParted app.