1 (edited by starbugs 2010-05-15 01:04:48)

Topic: [SOLVED] cannot access NTFS after resizing operation aborted

dear helpers :-)

i recently tried to resize (shrink) my ntfs partition with gparted (version 0.5.1) from an kubuntu 10.4 live cd.  unfortunately the operation aborted and now i cannot access the drive anymore.  the information gparted gives me is:

ntfsresize v2.0.0 (libntfs 10:0:0)
Device name     : /dev/sda5
NTFS volume version: 3.1
Cluster size       : 4096 bytes
Current volume size: 72727888384 bytes (72728 MB)
Current device size: 63293497344 bytes (63294 MB)
ERROR: Current NTFS volume size is bigger than the device size!
Corrupt partition table or incorrect device partitioning?

Unable to read the contents of this file system!
Because of this some operations may be unavailable.

is there any hope or is the data on the drive lost (i have a 2 days old backup - so it does not capture all the data on the drive....)?

searching for solutions, i found this forum....
i'd appreciate any help!  thanks in advance



Re: [SOLVED] cannot access NTFS after resizing operation aborted

The data should still be on the drive.

There is a tutorial on how to repair the problem:
Proposition of a tutorial for the NTFS size bug - NOT YET VALIDATED

Otherwise if you would like help then we'll need some more information.

Would you be able to provide the output from the following two commands?

fdisk -l -u

where one of the options is a lower case "L" and not the number one.

parted /path-to-your-device unit s print

where /path-to-your-device is something like /dev/sda.

With the above information we can determine how to capture your NTFS partition boot record.


Re: [SOLVED] cannot access NTFS after resizing operation aborted

i followed the steps from the tutorial and it worked fine for me.   thank you very much!!!

( only suggestion from my side:  "Look for the row 20, and replace the 3rd colum..." was misleading for me, as i wasn't sure, whether to look for the twentieth row or the one that starts with "...000020" - but maybe that's just misinterpretation from my side and this information is clear to others...)

thanks again very much for your help!



Re: [SOLVED] cannot access NTFS after resizing operation aborted

Thanks for reporting back and indicating you were successful.

I have edited the tutorial to enhance it with your suggestion regarding "0000020" and (third row).