1 (edited by LarryDC 2010-05-10 20:14:04)

Topic: [Solved]0.5.2:INACCESIBLE_BOOT_DEVICE: (SystemRescueCD 1.5.1)

Since subject version uses GParted 0.5.2 I thought I was safe.

The whole 39.08 GB drive was NFTFS running Win 2000. I reduced the NTFS to sda1 @ 9.76 GB and added 1 GB SWAP (sda2),  an 11.85 GB reiserfs (sda3) and a 14.65 GB ext4 (sda4).  I did it all in one operation. 

Perhaps I should have only have resized the NTFS, applied then shutdown?

1)  fdisk -l -u

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders, total 78165360 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x63116311

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    20482874    10241406    7  HPFS/NTFS
/dev/sda2        20482875    22587389     1052257+  82  Linux swap / Solaris
/dev/sda3        22587390    47439944    12426277+  83  Linux
/dev/sda4        47439945    78156224    15358140   83  Linux

2) parted /path-to-your-device unit s print

Model: ATA WDC WD400BB-53CA (scsi)
Disk /dev/sda: 78165360s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start      End        Size       Type     File system     Flags
1      63s        20482874s  20482812s  primary  ntfs            boot
2      20482875s  22587389s  2104515s   primary  linux-swap(v1)
3      22587390s  47439944s  24852555s  primary  reiserfs
4      47439945s  78156224s  30716280s  primary  ext4

3)  The above is just to substantiate the report.  I followed at greegthe geek's tutorial with  GParted forum » GParted » Proposition of a tutorial for the NTFS size bug - NOT YET VALIDATED

with gedakc's suggestion of using hexedit.  After I determined that greegthe geek counted in hex when he wrote "Look for the row 20, " (to us unwashed that is the '3rd row down, but numbered 00...20')

As pointed out the first reboot into windows after the "dd if=/some/where/myCurrentPbr.pbr of=/dev/sda bs=512 count=1 seek=63" does reequire letting the system do a chdsk as it suggests.

Everything is fine now.  I am going to post this to SystemRescueCD's forum as well (Ihave upgraded to ver. 1.5.3)
I performed the fix with PMagic 4.10 after reading Patrick's helpful comments on this site.
I will try my next resize with the straight GParted 0.5.2-9-Live.
Now I am concretizing my Thanks with a donation.

Larry De Coste


Re: [Solved]0.5.2:INACCESIBLE_BOOT_DEVICE: (SystemRescueCD 1.5.1)

Thank you Larry for reporting this problem and confirming the version numbers.

Recently the parted team found another race condition that can cause the "failure to inform kernel of partition changes" problem.
libparted: avoid race in informing the kernel of partition table changes

We will be investigating to see if perhaps this patch will solve this problem once and for all.


Re: [Solved]0.5.2:INACCESIBLE_BOOT_DEVICE: (SystemRescueCD 1.5.1)

(Moved to the Live Media section)

*** It is highly recommended to backup any important files before doing resize/move operations. ***

4 (edited by Oliverk48 2011-04-09 15:59:31)

Re: [Solved]0.5.2:INACCESIBLE_BOOT_DEVICE: (SystemRescueCD 1.5.1)

Interesting report, reminds me of something that happened to me awhile back big_smile BTW, thanks for the link to the greegthe geek's tutorial.

Oliver [at] hemorrhoid treatment X dot Org.