1 (edited by xceebeex 2010-03-06 18:00:57)

Topic: [Solved]Trying to resize external HDD

Well, I thought this would be fairly easy to do, but it has me nervous. I have a 250GB external drive that I want to resize so I can have a FAT32 partition for my ps3. Well stupid me figured everything would go smooth (and maybe it is) so I didn't back anything up that was already on there.

The resize has been running for about 5 hours already and has not completed. Does this seem right? Is there a way I can check the progress to make sure it is actually doing something and how close it may or may not be?

Also, if I were to cancel at this point, do I have any chances of my files remaining intact? Maybe I am just worrying for no reason, but I would have thought it would take much less time than this.

Any help is appreciated!


Re: [Solved]Trying to resize external HDD

Well it has been going for almost 14 hours and still no signs of progress. What are the chances that my files will remain intact if I cancel? I have read a few stories where people have stopped the process and all of their data seemed to still be intact. I really don't want to lose my data (my wife will kill me), but at the same time, without any indication of how far along this is, it could take days, weeks or years to complete.


Re: [Solved]Trying to resize external HDD

What version of GParted did you use?

Did you move the start of the partition?

External hard drives and the interface to these drives often have transfer speeds that are much, much slower than internal drives.  Hence it might take a very long time for the process to complete.

If you cancel the process, then there is a high likelihood that the file system will be in an inconsistent state and your data could be lost.  That is one reason why we recommend that you always make a backup prior to any partition editing operations.

What step does GParted say is currently active?

You can also check to see if there are any hardware errors by using the command "dmesg" and looking for problems with the external drive.

4 (edited by xceebeex 2010-03-05 18:14:03)

Re: [Solved]Trying to resize external HDD

I am using 0.4.6-1. I am not sure if I moved the start of the partition. All that I did was dragged the bar to the left and then I chose to format the new unallocated space as a FAT32 partition. Yea I understand that the USB interface is slower than an internal hard drive, but 14+ hours still seems excessive.

The process that it has been at for most of the time is the real resize. It ran the simulation and all of that pretty quickly. Where do I enter the dmesg command? I am not a Linux user so I am not too familiar with it.

If it is not done when I get home from work today, I might just take the chance and cancel it and hope that I don't lose anything. If I do, I will have to try some of the recovery software out there to recover as much as I can.

Also, out of curiosity, is your comment about losing data the political answer you are supposed to give to avoid liability? Do you have any personal experience or know of someone else who canceled the process and maintained their data?


Re: [Solved]Trying to resize external HDD

To enter the "dmesg" command you would need to open a terminal window.  This is similar to the Windows DOS Prompt.

Reading data across an interface is significantly faster than reading data and writing it back to a different location.  This has to do with buffering that occurs both in your computer and possibly also in your disk drive, and also with time required for repositioning the drive heads.

Since we do not know at a given point in time whether the blocks being copied are file system meta data, or user data, I can not say with accuracy what your chances of recovering the data are.  I do know that if no hardware errors are encountered, then leaving the process to complete successfully will mean that you should have all of your data preserved.

If you moved the left hand side of the bar to the left, then yes you are moving the file system.  You can expand the details control to see what steps have completed and what step is currently in progress.


Re: [Solved]Trying to resize external HDD

I did not move the left part of the bar at all, I only moved the right end to the left. Right now the only thing I can see is that it is on real resize and it says ntfsresize blah blah blah, but I can't expand anything else.

I ran dmesg but can't tell if something is wrong with it. I don't see anything that jumps out being wrong. The last message that I see is "Fixing recursive fault but reboot is needed." Does that mean anything?

7 (edited by gedakc 2010-03-06 00:58:09)

Re: [Solved]Trying to resize external HDD

From your description it does not sound like a move operation is in progress.

Let's check to see if ntfsresize is still running.  From the Terminal windows, enter the following command:
ps -ef | grep ntfsresize | grep -v grep

Does this command list an ntfsresize process running?

If ntfsresize has finished running then we might have encountered a problem that first appeared with Bug 575324 -  Copying a huge NTFS partition (e.g., > 100 GB) never finishes.

I am not sure about the recursive fault problem, but if a reboot is needed then that is not an option we should consider at this point in time.

EDIT:  If ntfsresize has finished and it appears that the problem is that GParted is simply waiting for ntfsresize to finish, then it is probably safe to quit GParted.  The only discrepancy will be that the partition will be larger than the file system.  This could be fixed by running GParted again and resizing the partition down to the same size again.


Re: [Solved]Trying to resize external HDD

I ran that command and here is what I get:

root     3561    3105    0 Mar04 ttyl     00:00:25  [ntfsresize]

Does that mean it is not currently running since that is yesterdays date?


Re: [Solved]Trying to resize external HDD

The date listed is the starting date of the process.  Since the process still shows up it is still executing.  You could confirm this by checking if the lights on the disk drive are still flashing to indicate activity.

10 (edited by xceebeex 2010-03-06 01:08:39)

Re: [Solved]Trying to resize external HDD

Hmmm, I am not sure if the LED on my Seagate External drive actually shows activity or just power. Right now it is just lit up a solid yellow, it is not blinking, but to be honest I am not sure if it ever blinked because I didn't pay attention.

EDIT: After looking up my manual, the drive is either asleep or no activity (depending on the definition of bright versus dimly lit). Either way, that means that it is doing nothing. So does that mean the process may have never really started?


Re: [Solved]Trying to resize external HDD

OK, well I decided to cancel the operation because there was no activity on the hard drive so it wasn't doing anything anyway. So I kept my fingers crossed as I booted into Windows to check to see if my data is there.

It looks like all of my data is there and it also looks like it resized the partition but didn't create the new partition. So I am going to back up all of my files now and try and start over.

Before I mark this as solved, any thoughts as to why it did this? Can I assume that the filesystem is OK and just try and add the new partition to the unallocated space or should I format the whole drive and start from scratch?

12 (edited by gedakc 2010-03-06 17:57:55)

Re: [Solved]Trying to resize external HDD

To check the integrity of the file system, try running a "chkdsk" on the drive from Windows.  This will either fix any problems that exist, or tell you if the file system is corrupt.

Assuming that everything is okay, you can then proceed to create your new disk partition in the unallocated space.


Re: [Solved]Trying to resize external HDD

Thanks for the suggestion. What I ended up doing was backing everything up on my desktop and I used gparted to format the drive and create the two partitions.

That process went MUCH better. It took a couple hours to back up all of my files, but once that was done gparted was able to format and create the two partitions in less than 5 minutes. I will mark this one as solved.

Thanks for the help!


Re: [Solved]Trying to resize external HDD

Glad to hear that you were able to solve the problem.  smile