1 (edited by gedakc 2010-02-18 17:18:21)

Topic: SOLVED - Volume size is bigger than device size

I used Parted Magic 4.2 to shrink the ntfs partition to make room for Linux Mint 8 on the new partition
sda2.    Linux Mint 8 is installed and working on sba 2, but Windows XP on sda 1 is not available.  The message is the familiar “volume size is bigger than device size”.

Here is the output of the two commands that you asked of others with this problem.
cindy@cindy-desktop ~ $ sudo fdisk -l -u
[sudo] password for cindy:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xa304a304

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   125580104    62790021    7  HPFS/NTFS
/dev/sda2       125580105   154240064    14329980   83  Linux
/dev/sda3       154240065   156296384     1028160   82  Linux swap / Solaris


cindy@cindy-desktop ~ $ sudo parted /dev/sda unit s print
Model: ATA ST380012A (scsi)
Disk /dev/sda: 156301488s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start       End         Size        Type     File system     Flags
1      63s         125580104s  125580042s  primary  ntfs            boot
2      125580105s  154240064s  28659960s   primary  ext3
3      154240065s  156296384s  2056320s    primary  linux-swap(v1)

You can find the uploaded mbr and pbr as follows:



I'm using Linux Mint 8 which is installed on sda2.   I installed Linux Mint 8 after resizing to make room for it, therefore,  Windows XP on sda 1 was not found and the computer boots directly into LM8.    What do you think about reinstalling Linux Mint after we find sda1 so it will dual boot?

Thanks in advance for your efforts in attempting to solve this problem.


Re: SOLVED - Volume size is bigger than device size

Since you were trying to shrink the partition, we will decrease the NTFS volume size to fit within the partition.

The change I have made to the file is from a length of 156,296,312 sectors:
00000020   00 00 00 00  80 00 80 00  78 E4 50 09  00 00 00 00
To a new length of 125,580,041 sectors:
00000020   00 00 00 00  80 00 80 00  09 33 7C 07  00 00 00 00

Note:  The NTFS volume size is always 1 sector less than the total number of sectors in the partition table entry because the NTFS backup sector is not considered part of the NTFS volume.

To apply this change:

1) Download the new NTFS PBR: sda1-mattvig_new.pbr

2) Load the new NTFS PBR on your hard disk.
NOTE:  Be extra careful when entering the commands.  Data loss could result otherwise.

dd if=sda1-mattvig_new.pbr of=/dev/sda bs=512 count=1 seek=63

3) Reboot the computer

4) Check that the file system is recognized in GParted

5) If all seems fine then I would advise booting into Windows and running "chkdsk /f /r" multiple times, until there are no more faults.

NOTE:  If Windows does not boot (perhaps because it was not recognized during the Linux Mint install), then you have several options two of which are:

A) Configure grub from Linux Mint to boot Windows

B) Rebuild Windows XP boot by booting from the install CD and running the following commands:

bootcfg /repair

Then re-install Linux Mint 8 as you suggested.

Like many things, there are other ways to solve this problem too.


Re: SOLVED - Volume size is bigger than device size

gedakc,  Thanks for the prompt reply.  I'm away from the problem computer until next week.  I'll post my results then and hopefully be able to add "solved" to the heading.


Re: SOLVED - Volume size is bigger than device size

Thanks again for the help in finding my Windows partition.  Your instructions were excellent and worked perfectly.   I used the command "sudo update-grub" from Linux Mint and grub2 was reconfigured for dual boot.   You can add SOLVED to the heading of my posts.


Re: SOLVED - Volume size is bigger than device size

I am glad to hear that the problem is now resolved.  smile

I have edited the initial post to prefix the title with SOLVED.