Topic: SOLVED - Error Current NTFS volume is bigger

Hello everybody, i got the same Error like many other users too. "Current NTFS volume size is bigger than the device size!" after i try to split an existing logical drive. So i read in the forum but cant help myself. I try to get all Informations you need to help me to set the MBR and PBR right.

fdisk -ul

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes

Disk identifier: 0xa55ea55e
Device Boot      Start         End      Blocks   Id  System

/dev/sda1   *          63   204796619   102398278+   7  HPFS/NTFS
/dev/sda2       204796620   976768064   385985722+   f  W95 Ext'd (LBA)
/dev/sda5       204796683   266229179    30716248+   7  HPFS/NTFS
/dev/sda6       409593303   976768064   283587381    7  HPFS/NTFS
/dev/sda7       266229243   409593239    71681998+   7  HPFS/NTFS

Partition table entries are not in disk order

Disk /dev/sdb: 1024 MB, 1024966656 bytes
255 heads, 63 sectors/track, 124 cylinders, total 2001888 sectors

Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x002d9bf6
   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63     2001887     1000912+   b  W95 FAT32
Partition 1 has different physical/logical endings: 
phys=(123, 254, 63) logical=(124, 155, 63)


Model: ATA WDC WD5000BEVT-0 (scsi)
Disk /dev/sda: 976773168s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start       End         Size        Type      File system  Flags
1      63s         204796619s  204796557s  primary   ntfs         boot
2      204796620s  976768064s  771971445s  extended               lba 
5      204796683s  266229179s  61432497s   logical   ntfs
7      266229243s  409593239s  143363997s  logical   ntfs
6      409593303s  976768064s  567174762s  logical   ntfs


sda1:  http://www.mediafire.com/?ifyjnwk5ntr
sda2:  http://www.mediafire.com/?15524zzoz4z
sda5:  http://www.mediafire.com/?zwzcztlujt4

so i hope you can help me

best regards jay


Re: SOLVED - Error Current NTFS volume is bigger

To take some of the guessing out of solving your problem, which partition(s) did you resize?

Which partition(s) are experiencing the error message?
Note that You can boot GParted Live to see which partitions have an exclamation point next to them.  Double-clicking them will bring up a dialog box with an error message.


Re: SOLVED - Error Current NTFS volume is bigger

Ok sorry for the missing informations.
The error is on partition 5 here is the log:

GParted 0.5.0

libparted 1.9.0
Dateisystem (ntfs) auf /dev/sda5 überprüfen und reparieren  00:00:01    ( FEHLER )
/dev/sda5 kalibrieren  00:00:01    ( ERFOLG )
Pfad: /dev/sda5
Anfang: 204796683
Ende: 266229179
Größe: 61432497 (29.29 GB)
Dateisystem auf /dev/sda5 auf Fehler überprüfen und (falls möglich) diese beheben  00:00:00    ( FEHLER )
ntfsresize -P -i -f -v /dev/sda5
ntfsresize v2.0.0 (libntfs 10:0:0)
Device name : /dev/sda5
NTFS volume version: 3.1
Cluster size : 4096 bytes
Current volume size: 104855831040 bytes (104856 MB)
Current device size: 31453438464 bytes (31454 MB)
ERROR: Current NTFS volume size is bigger than the device size!
Corrupt partition table or incorrect device partitioning?

Im not sure about the name before i try to partition the device is it possible that sda2 was the old name of it?
So after i partition the device i had sda5 with ~29,29GB and sda7 with ~68,36GB. The root of this two partitions had ~100GB
I took a screenshot of it i hope this can help you:


Re: SOLVED - Error Current NTFS volume is bigger

CAUTION:  In your first post, the file beside the label "sda5:" is actually named "sda3-jay.pbr".  I will proceed as if you meant this to be the file sda5-jay.pbr.  If this is not the case then please report back with the actual sda5-jay.pbr file.

Now assuming that we are working with sda5-jay.pbr, the following is what I have discovered.

From the parted command output I can see that the size of partition sda5 is 61,432,497 sectors.
From the sda5-jay.pbr file I can see that the NTFS volume sees itself as 204,796,544 sectors.
Hence this where the problem lies.

In this situation, I think our best option is to decrease the NTFS volume size to fit within the partition size.

The change I have made to the file is from a length of 204,796,544 sectors:
00000020   00 00 00 00  80 00 80 00  80 F2 34 0C  00 00 00 00
To a new length of 61,432,496 sectors:
00000020   00 00 00 00  80 00 80 00  B0 62 A9 03  00 00 00 00

Note:  The NTFS volume size is always 1 sector less than the total number of sectors in the partition table entry because the NTFS backup sector is not considered part of the NTFS volume.

To apply this change:

1) Download the new NTFS PBR: sda5-jay_new.pbr

2) Load the new NTFS PBR on your hard disk.
NOTE:  Be extra careful when entering the commands.  Data loss could result otherwise.

dd if=sda5-jay_new.pbr of=/dev/sda bs=512 count=1 seek=204796683

3) Reboot the computer

4) Check that the file system is recognized in GParted

5) If all seems fine then I would advise booting into Windows and running "chkdsk /f /r" multiple times, until there are no more faults.

Which version of GParted and / or GParted Live did you use for resizing?


Re: SOLVED - Error Current NTFS volume is bigger

It works thank's for your help. I used the newest version  0.5.0


Re: SOLVED - Error Current NTFS volume is bigger

It is good to hear that the problem is now solved in your situation.  smile

To help other users when searching for solutions, I have edited the first post and prefixed the title with "SOLVED".