Topic: recover files from an xfs hard drive

Hello comrades,
first in short, my personal backround:
I have never programmed anything in my life. most of what I have ever done, was to simply "copy and paste" someting that was already finished. also my english is very bad, please excuse that to.

the problem:
my Sister was using an olderr Buffalo NAS Station, it felt down and broke.
like the idiot I am, there was no backup data elsewhere and i didnt even tried to repair the NAS.
I simply took out the hard drive and connected it directly with my pc. and who could imagine that... -.- windows could not read the format.
so as my online research advised me, i downloadet GParted and tried to recover the data on it.
GParted told me that the biggest partition on the hard drive was written in xfs, so i tried to search for file systems on it.

GParted found data, I tried to fiew it and the error window showed up with the message:
"v1 inodes unsupported. please try an older xfsprogs"

Please if anyone can help me in a way, that even a monkey behind a keyboard could understand the different steps, i would be very pleased smile

the data is very importand for me, if i get it back, i would be pleased to spend something for the future development of GParted.

a nice day to all! smile


Re: recover files from an xfs hard drive

If the recommendation is to try an older version of xfsprogs, then you might try using an older version of GParted Live.  The versions of packages, such as xfs-progs, are outlined in the associated "packages-{version}.txt" file on the download section of the web site.

You might also consider trying photorec (included on Gparted Live) to scan the drive surface looking for files it recognizes.  This is a painstaking process, and the file names are not retained, but sometimes this can yield good success.  I've used it myself to recover files.


Re: recover files from an xfs hard drive

thank you for the answer smile
but i could not find the programm, photo rec when i started Gparted Live...

what i found was the option: "try data recovery", in the GParted Window (or file recovery* i dont know how its translated, i tried GParted with the german language option)
this took long time, and in the end it could not show me what it found, only the error wich i mentioned.

Is it a good idea, to try and install a linux ubuntu partition, and then try and run PhotoRec with it?


Re: recover files from an xfs hard drive

At this point in time there is no indication that file system is corrupt, just that the XFS file system uses an old format with V1 inodes, which the current tools no longer support.

You action plan should be:
1) Boot PC using older GParted Live CD, version 0.23.0-1.
   (Has xfsprogs 3.2.4, the last version to support XFS with V1 inodes).
2) Use GParted app to identify the the XFS file system.
3) Use GParted app to identify another file system to restore the wanted file too.
   (Since your using Windows, I expect it will be either FAT32 or NTFS).
4) Mount the XFS file system.
5) Mount the restore file system.
6) Copy wanted files.

Detailed commands for above steps (4) to (6).

4) Mount the XFS file system read-only.
4.1) Open a "Terminal".
4.2) Type the following:

sudo su -
mkdir /mnt/xfs
mount -o ro /dev/sdb1 /mnt/xfs

This assumes the XFS file system is /dev/sdb1.  Change as needed.

5) Mount the restore file system.
5.1) Still in the terminal type the following:

mkdir /mnt/restore
mount /dev/sdc1 /mnt/restore

This assumes the restore file system is /dev/sdc1.  Change as needed.

6) Copy wanted files.
6.1) Create restore directory (folder).  Still in the terminal ...

mkdir /mnt/restore/fromNAS

6.2) Copy all files from the NAS XFS file system.

cd /mnt/xfs
cp -av . /mnt/restore/fromNAS

Optionally only copy specific files by naming them rather than using . (dot) which means current directory (and because of the -a flag, everything below it).
6.3) Unmount file systems

cd /
umount /mnt/restore
umount /mnt/xfs