Topic: Trouble compiling on CentOS 4.4

I installed parted from source, now tried to install Gparted 3.3.  When I configure, this is where it halts:

checking for libparted >= 1.7.1... Found libparted 1.8.1        OK
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GTKMM... Package gtkmm-2.4 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkmm-2.4.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkmm-2.4' found
configure: error: Package requirements (gtkmm-2.4 > 2.8 ) were not met:

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTKMM_CFLAGS
and GTKMM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I tried ./configure PKG_CONFIG_PATH=/usr/bin/pkg-config and that didnt work either.  I installed gtkmm24 and gtkmm24-devel via rpm, so I know its there:

[root@hondaserver1 gparted-0.3.3]# locate gtkmm-2.4


Can anyone lend me a hand?  I really could use this package.  In fact, I'm planning on adding an additional 2tb of storage today, and this tool would be golden.

Thank you.


Re: Trouble compiling on CentOS 4.4

well the problem is around devel packages. I wonder if you even can install GParted on centos. I tried more times and never succeed : Centos is a *very* stable distro (the best i have ever seen) but the reason is that it usually doesnt allow you to install devel deps !
To compill GParted, you need gtkmm-2.4-devel and glibmm-2.4-devel, and parted-devel and so on ...

GParted-project Admin
Former GParted-LiveCD maintainer (2007)