1 (edited by dals 2006-12-07 00:16:02)

Topic: ubuntu login failure after using GParted [SOLVED]

(maybe this is not the right forum... my excuses, first post ever)

I have just finished resizing/moving my (fat32)windows(XP) and (ext3)ubuntu(5.10) partitions and creating a new bridge fat32 partition in between. Everything ok with GParted (0.3), but afterwards I get an error when trying to log in into ubuntu: I get a message of the type "your session lasted less than 10 seconds and it's probably due to an error, try logging into console mode and fixing the problem", the details being the following:

       /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
       /etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp
                  -u /var/run/utmp -x "/var/lib/gdm/: 0.Xservers" -h "" -l ":o" "diana"
       /etc/gdm/Xsession: Beginning session setup...
       mkdtemp: private socket dir: No space left on device

I do manage to log into graphic mode as root user instead of the particular user name "diana" and there is indeed space left. Any ideas? (maybe of the right forum to post this in? : ) )

Thanks in advance


Re: ubuntu login failure after using GParted [SOLVED]

Hi dals, welcome to our forums smile

How much space is left on the device? it's usually a good idea to have at least 10% of free space.
I think root has some reserved space (about 5%), so this can explain why root can login while a normal user can't.


Re: ubuntu login failure after using GParted [SOLVED]

Thanks plors. you were right (how strange : ) ) , I just shoved some stuff to the new data partition (that was the whole idea after all) and i was able to log in normally. (Then i had a little problem with mounting the new partition once and for all but i sorted it out before asking you by adding a line to the fstab file).

Hasta pronto! : )