1 (edited by esuhl 2021-05-18 20:55:19)

Topic: [SOLVED] eMMC drive not detected...?

Hi :-)

I have an Asus E210MA laptop with a built-in eMMC storage drive, and I've installed an additional M.2 NVMe stick.

GParted Live detects the new M.2 stick (and any attached USB drives), but not the internal 64 GB eMMC device.

When I boot into Windows 10 and run diskmgmt.msc, both the eMMC and M.2 drives are detected.

Is there any way to get GParted Live to detect my eMMC SSD?



Re: [SOLVED] eMMC drive not detected...?

See Running gparted from a Command Line in the GParted Manual for instructions.

Please report the output from this command so that I can see the name of the device and in future make GParted automatically detect the eMMC

sudo lsblk -o name,maj:min,rm,size,ro,type,fstype,label,mountpoint


Re: [SOLVED] eMMC drive not detected...?

Awesome!  Thanks for your work developing such cool software. :-)

Here's the output of the above command:

user@debian:~$ sudo lsblk -o name,maj:min,rm,size,ro,type,fstype,label,mountpoint
loop0          7:0    0 335.3M  1 loop squashfs              /usr/lib/live/mount/rootfs/filesystem.squashfs
sda            8:0    1   1.9G  0 disk iso9660  GParted-live 
|-sda1         8:1    1   390M  0 part iso9660  GParted-live /usr/lib/live/mount/medium
sdb            8:16   1   972M  0 disk iso9660  GParted-live 
|-sdb1         8:17   1   970M  0 part vfat     1GB-SD-CARD  /tmp/usb
mmcblk0      179:0    0  58.2G  0 disk                       
|-mmcblk0p1  179:1    0    16M  0 part                       
|-mmcblk0p2  179:2    0  56.9G  0 part ntfs     Old OS       
|-mmcblk0p3  179:3    0     1G  0 part ntfs     RECOVERY     
nvme0n1      259:0    0 232.9G  0 disk                       
|-nvme0n1p1  259:6    0     2G  0 part vfat                  
|-nvme0n1p2  259:7    0   128M  0 part                       
|-nvme0n1p3  259:8    0   120G  0 part ntfs     Win10 NVMe   
|-nvme0n1p4  259:9    0 105.8G  0 part ext4     Arch         
|-nvme0n1p5  259:10   0     5G  0 part swap     swap         
mmcblk0boot0 179:256  0     4M  1 disk                       
mmcblk0boot1 179:512  0     4M  1 disk                       

So mmcblk0 is that disk that isn't detected.

Let me know you need any further details.

Cheers :-)


Re: [SOLVED] eMMC drive not detected...?

Genuinely thank you.  You have identified a regression I introduced into GParted 1.3.0 which has cause it to not show SD/MMC cards.

1. Specify the device name on the command line, as described above.
2. Use GParted 1.2.0.


Re: [SOLVED] eMMC drive not detected...?

No problem -- and thanks for the workarounds.

I tried GParted 1.2.0 and can confirm that the eMMC drive IS detected in that version.

Cheers :-)