1 (edited by FERNDX 2020-04-23 06:36:17)

Topic: Can't resize boot partition with GParted

Hello. I have this problem. When I start Ubuntu I get the message: Disk space is low in boot/EFI. I searched for solutions to this and I found that I should erase the old kernels to free space in boot/EFI. I did that and I still get the message that disk space is low in boot/EFI. Then I tried to resize the boot partition with GParted. The boot partition is dev/sda1 and it's size was around 33MB. I enlarged the partition with 600MB of free space that were before it. But when I tried to enlarge it with GParted I got an error message. Then when running GParted again it appeared a warning sign next to the boot partition. I right-clicked the partition and then clicked on information. It said that I needed to enlarge the file system clicking the check partition option. I did that and I got an error.

Here is a screen shot of GParted screen:

https://i.imgur.com/HW7mveG.png

What I want now is to know how to enlarge the file system of the boot partition. The partition says it has a size of 660 MB and 32.52 MB are used. But it says it only has a free space of 959 KB.

I hope somebody could help me.

2

Re: Can't resize boot partition with GParted

Normally, check partition would grow the filesystem to fill the partition.
I see the partition appears locked. I guess you run GParted from Ubuntu installed on the disk in question. Perhaps the o.s. mounts the partition. You can try to unmount the partition /dev/sda1 or try to run Gparted Live (from a bootable cd or usb stick). GParted Live doesn't mount any disk partition by default.

*** It is highly recommended to backup any important files before doing resize/move operations. ***

3

Re: Can't resize boot partition with GParted

I ran GParted from an Ubuntu Live installation dvd. I checked that the boot partiton was unmounted, then I clicked on check partition and I still got an error.

Here is an screenshot of the partitions of my harddrive shown in GParted running from an Ubuntu Live installation dvd:

https://i.imgur.com/TRU0Vew.png

4

Re: Can't resize boot partition with GParted

I had the same problem, sought for a loyal solution and found only this one (manual, but very simple).

Just save manually the EFI folder from your efi partition (your sda1), or better make an image of this partition via Disks Utility,
then delete the EFI partition,
create the new bigger one (in fat32),
flag it as boot/esp in Gparted,
and COPY MANUALLY there your EFI folder.
That's all! It works OK with Ubuntu_20 and Windows_8.

My Gparted (v.1.0 on Live USB Ubuntu20) can neither shrink directly a small EFI partition nor shrink it via repair command (after deleting the partition, creating the new bigger one and restoring of original EFI partition with Disks).
So I tried the Russian way (the most simple and direct decision) -- and it has worked momently like the simple pencil in Space.

Всё просто! Привет из России!