Re: GParted webbooting

To summarize, GParted live 0.20.0-3 amd64 works via PXELinux memdisk, however, it's not for i486 and i686-pae ones. I have to add "vmalloc=256MB" to the boot parameters for i486 and i686-pae release. However, I am not sure if there is any side effect. I tested i686-pae on the virtual machine with 512 MB, booting either from iso or PXELinux, they all worked.
Therefore it looks safe to add "vmalloc=256MB" for i486 and i686-pae ones.
However, booting from memdisk with pxelinux is not used very widely. I believe it's only one in thousands. Especially now amd64 release works, only i486/i686-pae failed. As Ady suggested to me via email, he said the best choice is to have a doc to describe this. I agreed with him.
How about your suggestion?



Re: GParted webbooting

I can confirm i686-pae is also working after having added vmalloc=256m to boot parameters.


Re: GParted webbooting


a while ago I reported problem with booting gparted_live using memdisk.
Reading now the information about vmalloc I decided to boot gparted_live using grub2 and memdisk again.
I have used memdisk from syslinux6.03

As first I used gparted-live-0.19.1-4-i486, fully booting not possible.
The next: gparted-live-0.20.0-3-i486, as expected booting not possible too.
Then: gparted-live-0.20.0-3-amd64, gparted_live was fully booted, with (Default settings) as well as Gparted Live (To RAM...), no problem with using.

PartedMagic is using the parameter vmalloc too.
Always as the size of the iso file was bigger, the vmalloc grow up with, 256, 288, 320, 384, and there were no problems reported because of to big vmalloc value. Only time to time somebody, who tried to boot never iso with the old vmalloc value reported problem.

At least the vmalloc should be bigger then the size of the iso.
As the gparted_live is 230 big, the vmalloc can be lower to 248, or 240 but I do not think the value 256 will make problems and 256 should be use in all Gparted_live versions.



Re: GParted webbooting

dud225 wrote:
gedakc wrote:

dud225, are you saying that you can or cannot boot the 0.20.0-3 amd6 live image?

Booting 0.20.0-3 amd64 through memdisk is working properly on my computer.
I did not try i686 build however.

Thank you for the clarification.  It sounds like 0.20.0-3 works for you.

The fact that 0.20.0-3 is in the testing folder is simply an indication that additional testing has not been done with the image.  The fact that the image is in the testing folder is not an indication that it is any less stable than a stable release.  Stable releases simply go through more testing to ensure they boot on a variety of computers, though not necessarily all computers because it is impractical for us to test on all computers.  :-)