1 (edited by yogiHB 2011-11-21 13:57:15)

Topic: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk


I'have a strange problem with my hard disk.
The first point is that the ubuntu installer (10.04, 11.10) does not recognize any partions on this disk.

The disk (ATA Maxtor 6Y160M0, port 2) was in the computer with XP preinstalled, I shrinked this partition using partition magic, made up a data partiton (fat32) for data exchange and installed 10.04 in a logical partition.

Due to system instability the computer switched off several times, without doing any harm to ubuntu. Nevertheless once ubuntu broke as well as the XP that wasn t even booted (\windows\system32\config\system lacks or is damaged).

So I installed ubuntu 10.04 on second disk (ide) to save the data from the sata disk.
Now I learned that it resulted from a overloaded multicontact plug. In a separate wall plug the computer is running stable now.
Until now I used this disk only for data, but know I need to install a newer version of ubuntu, but the installer does not recongnize the partitions on this disk.

With rescatux (supergrub 2) I repaired the bootsektor, that is now booting ubuntu on the second disk and the defect XP. I used parted to delete partitons and swap files I did not need any longer, without problems. Only the disk utility is showing several million TB of free disk space beyond the end of the disk.
Nothing changed.

This extra space shows not up in gparted, fdisk or testdisk, altough in the live system gparted showed several MB of unallocated space at he end of the disk.
Here  are some informations about the system:

~$ uname -a
Linux wallaby 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 15:27:15 UTC 2011 i686 GNU/Linux

~$ lsb_release -a 
LSB Version:    core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID:    Ubuntu
Description:    Ubuntu 10.04.3 LTS
Release:    10.04
Codename:    lucid

~$ sudo parted -l
[sudo] password for jmuehlis: 
Modell: ATA SAMSUNG SP0842N (scsi)
Festplatte  /dev/sda:  80,0GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ       Dateisystem     Flags
 1      32,3kB  132MB   132MB   primary   fat16           versteckt
 3      132MB   17,1GB  16,9GB  extended
 5      132MB   16,3GB  16,2GB  logical   ext4
 6      16,3GB  17,1GB  756MB   logical   linux-swap(v1)
 2      17,1GB  80,0GB  63,0GB  primary   ext4            boot

Modell: ATA Maxtor 6Y160M0 (scsi)
Festplatte  /dev/sdb:  164GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ       Dateisystem  Flags
 1      32,3kB  21,1GB  21,1GB  primary   ntfs         boot
 2      21,1GB  164GB   143GB   extended               lba
 5      58,9GB  157GB   98,0GB  logical   fat32        lba

sudo blkid -c /dev/null 
/dev/sda1: SEC_TYPE="msdos" UUID="355F-13E2" TYPE="vfat" 
/dev/sda2: UUID="05fce77f-c63f-497d-95c9-3bba56f67bf1" TYPE="ext4" 
/dev/sda5: UUID="e4ce4f7e-439b-470a-b567-ecf0c9ac5fa8" TYPE="ext4" 
/dev/sda6: UUID="3b404224-316d-4239-8557-40c5a70b34e0" TYPE="swap" 
/dev/sdb1: UUID="1C48335B4833333E" TYPE="ntfs" 
/dev/sdb5: LABEL="VOLUME" UUID="4AAA-B4DF" TYPE="vfat" 

cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=e4ce4f7e-439b-470a-b567-ecf0c9ac5fa8 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=3b404224-316d-4239-8557-40c5a70b34e0 none            swap    sw              0       0
#UUID=bf15a6df-5441-4451-a238-1fab6d46f50a /home/jmuehlis/Privat ext4    relatime0    2
UUID=05fce77f-c63f-497d-95c9-3bba56f67bf1 /home/jmuehlis/Datenlokal ext4    relatime    0    3

(sudo pvs
sudo vgs
sudo lvs
commands not found)

~$ cat /etc/mdadm/mdadm.conf
cat: /etc/mdadm/mdadm.conf: Datei oder Verzeichnis nicht gefunden
~$ cat /proc/mdstat
Personalities : 
unused devices: <none>
~$ sudo mdadm --detail --scan 
sudo: mdadm: command not found

Booting with a usblive stick:

~$ uname -a
Linux ubuntu 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

In the output of cat /var/log/partman on the live usb system the disk sdb does not occur, but in the syslog (cat /var/log/syslog) (to big to upload).
Furthermore I tried another distribution, that might use another installer and in fact  fedora 16 recognizes the disk as  BIOS RAID SET STRIP.
In the bios no raid functionality is activated, nor did I ever try to install or use a raid volunteerly.

I then installed dmraid:

~$ sudo dmraid -r /dev/sdb
/dev/sdb: pdc, "pdc_gagigfjd", stripe, ok, 320172928 sectors, data@ 0

I have no idea if this in fact means that there is an raid on the disk.

I would be grateful if somebody could help me to understand what is wrong.
If I understand it right partman is also based on parted?

Thanks for your help


P.S. Just started fedora 16 live and the disk utility in fact shows a 164 GB RAID Component. gparted is not avalable.


Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk

You might want to double check your BIOS setup to ensure that RAID is not enabled.

If I recall correctly, the fedora 16 .iso image file does not ship with gparted.  You can install it though using (as root) "yum install gparted".

3 (edited by yogiHB 2011-11-16 12:33:21)

Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk

Hi Gedakc,

I already triple checked it.

Serial ATA configuration is:

Serial ATA Controller [Enabled]
RAID Enabled           [Disabled]

With this configuration NVIDIA and Silicon Image Raid Tools are both unaccessible. According to manual I will have to enable RAID enabled to work with these tools.
Would it make sense to activate RAID and to check the status of these tools?

By the way I booted an old Knoppix 5.2 and started qtparted v0.4.5-cvs.
Here I could see /dev/sda with the partitioning scheme I expect.
This schem could also be seen for /dev/mapper/pdc_gagifjd, while two devices with the same name but ending on 1 and 5, probably the two partitions, showing a slightly different partition scheme.
I don t know if this helps.

I will know check if I can install gparted during live usb fedora 16...

Thanks for your help


P.S.: Now I installed gparted (Fedora live usb) and started gparted in the terminal:
[root@localhost liveuser]# gparted
libparted : 3.0
device-mapper: remove ioctl failed: Device or resource busy
parted was unable to re-read the partition table on /dev/mapper/pdc_gagigfjd (No such file or directory).  This means Linux won't know anything about the modifications you made.
device-mapper: create ioctl failed: Device or resource busy
device-mapper: remove ioctl failed: Device or resource busy

In gparted I get the same partiton scheme as with knoppix.
pdc_gagigfjd1  ntfs                 19.66 GB
pdc_gagigfjd2  extended        133.00 GB
unallocated                             35.66 GB
pdc_gagigfjd5                         91.26 GB
unallocated                              6.59 GB

and the same for sdc (sdc1, sdc2, sdc5).

For this I get warnings that fielsystem tools for ntfs (ntfsprogs) and fat32 (dosfstools, mtools)  are not installed. In the package manager they are marked as installed.

In my ubunt installation I don t get any messages:
sudo gparted
libparted : 2.2

I hope you or somebody else can help me to understand this and maybe to solve this.

Thanks yogiHB


Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk

It certainly sounds as if there are some RAID signatures on the hard disk drive.


Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk

gedakc wrote:

It certainly sounds as if there are some RAID signatures on the hard disk drive.

That is what I thought to have found out, but I have not the slightest idea why.

If there is a simple rather sure way to remove them I would do it. The data are saved elswhere in case it doesn t work, but it would be easier to retain the data and might be able to restore the XP for some special programs not running under wine and some games for children.

So do you have any idea what i might have did to that drive and fix it.

Is it possible that this occurs due to power off. Or is it possible that XP was installed using a raid.

Thanks for the help



Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk


finally I solved the problem. One possibility is to deinstall dmraid, the program necessary for RAID recognition, prior to installation. Then the installer will not recognize the RAID and you can install on any partition of the disk.

Finally I found a thread that solved the Problem by deleting the RAID signature:

dmraid -rE

This deleted the RAID signature without doing any harm. Ubuntu oneiric was installed and runs without problems.

What I didn t understand is why gparted does not recognize the RAID using ubuntu, while using Fedora 16 it recognized the RAID.
Furthermore I do not understand where the RAID signature came from:
1. The system switched of several times due to an overloaded mulitplug.
2. Did someone maybe activated the RAID once? Would the signature be correct for the nvidia or silicon image controllers on the p5n32-sli Asus Motherboard

Finally I am a bit disapointed, that the Terrabytes of free disk space do not show up any longer usign the disk utility of ubuntu. Ok I did not really believe that they are there, but...

Thanks for your help


P.S.: If suitable I could also enter the links to the threads that also helped me.


Re: [Solved] Problems with disk partioning - 18MioTBfreeattheendofthedisk

P.S.: If suitable I could also enter the links to the threads that also helped me.

It is always useful to know details on the various problem solutions.
So, your links are welcome.

*** It is highly recommended to backup any important files before doing resize/move operations. ***