1 (edited by Muad'Dib 2009-09-26 23:45:17)

Topic: [SOLVED] modify GPT possible?

I have a hardware raid. Gparted was easy to use to set up the volume for a single 4.5 TB partition.

Then I expanded the volume. Now there's an extra 1.5TB in the volume.

But I can't use the new space at all!

Gparted doesn't let me creata a new partition with the space, or expand the existing one to fill it. It sort of makes sense, it's like cutting and pasting a small disk onto a new larger disk without formatting the entire disk first.

At least I think that's what parted is complaining about in this error message :

"Not all of the space available to /dev/sdb appears to be used, you can fix the GPT to use all of the space (an extra 2929687040 blocks) or continue with the current setting?"

So since the message says "you can fix the GPT..." - HOW do I fix the GPT???


Re: [SOLVED] modify GPT possible?

To work around this problem, you will need to run parted (not gparted) from the command line.  It will prompt you with an option to use the new disk space.  You can then instruct parted to use the extra space.  After doing this you should be able to exit parted and then start gparted and continue as normal.

This problem has been reported in the following bug:


Re: [SOLVED] modify GPT possible?

I tried parted from the command line and it quit immediately with an error that the (ext3) filesystem had an "unsupported feature".  Some googling made me think that it might be griping about resize_inode, but I can't remove it. That generates an error too.

The error about the unused space makes the most sense to me but everything that's supposed to work, hasn't.

I want to try to create an XFS partition.

Is there a way to grow an XFS partition from the command line? I'm using Fedora 10 (not an option).


Re: [SOLVED] modify GPT possible?

OK. I get it.

Finally. Such a pain but I got it.

The magic trick was to just type "#parted /dev/sdb" I'd always been running it like "#parted /dev/sdb1"

When I ran it against "/dev/sdb" and did a print command it gave me the "do you want to fix the GPT?" - I had to tell it twice to fix the GPT and that was that.

Then I was able to install the XFS tools for Fedora, then use Gparted to make an XFS partition taking up just the new space, then used Gparted to combine the space into one. I'm impressed with how fast that went compared to doing anything with ext3.


Re: [SOLVED] modify GPT possible?

'Glad to hear that you now have a solution to the problem.  And thank you for marking the title with solved.  smile


Re: [SOLVED] modify GPT possible?

I had the same problem amd really got it sorted out in seconds with your help.Ty


Re: [SOLVED] modify GPT possible?

Since version 0.12.0, GParted is able to update the GPT to recognize added disk space.